Alteryx Designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

.sas7bdat file gives an error "Error reading the dictionary - filename may be invalid"

Alteryx Partner

We're having a same issue as reported by "Error reading the dictionary - filename may be invalid" from jshah120, marked as solved. Yet none of the solutions seem to be working.


We're on Alteryx version, receiving several files from a SAS environment trasferred to a windows environment where Alteryx runs.


Capture SAS Error.PNGNot sure whether I should raise it as a new topic; but it's not solved : I'm out of ideas what to try here... where to start looking.
- I tried renaming the file
- I tried copying the file to another location
- No weird filenames or paths."D:\temp\renamed.sas7bdat"
- We can open it through SAS
- The file is not all that big : 4.5 Mb

- I've looked at the properties on the file and the security side, yet that doesn't seem to be different from files that do work...


What else is there to try - other ideas on how to troubleshoot this?


If I use the directory input from alteryx, I can see that alteryx can "see the file", I can also force it to load into txt format; then I can se lots of gobble-g... but not possible from there to then actually do something with the data...


Thanks if someone has any pointers in the right direction what I should be looking at?


@KoCo - other users who experienced this issue have upgraded to 11.3+ and no longer run into it. Is upgrading an option for you?

Sophia Fraticelli
Premium Support Advisor
Alteryx, Inc.