Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

"The external program "cmd" returend an error code: 1




its Tool #275: Tool # 105 (Field Summary). Pls have a look at the attachment. I have no idea why it doesnt work anymore. It someday worked, but right now it doesnt (Win10 - Most up to date version). 


Any idea what to fix?? I need that operator very urgent. 






Alteryx Certified Partner
Alteryx Certified Partner

I've reported the issue to @JessicaS (Alteryx).


We believe that it is due to having a space in the temp path (e.g. D:\Temp Space).


It has been forwarded to the dev team.  The workaround is to modify alteryx user setup to use Temp_Space or TempSpace as the directory.




Alteryx ACE & Top Community Contributor

Chaos reigns within. Repent, reflect and reboot. Order shall return.

Hi @cschra,


@MarqueeCrew is correct.


This issue is likely due to your temp space directory containing a space.  Try adjusting the path to a location that does not contain spaces and please let us know if this resolves the error. 


Mark previously reported this to us and our development team is aware of this and looking into the issue.  I've  made a note to update this thread along as updates come in on this issue.





Jess Silveri
Premium Support Advisor | Alteryx

Hi Jessica,


I have the same issue, do you have an update on why it is happening? I don't have space in the reference directory.


Hi @xiaomofenghai,


The issue reported in this thread turned out to be due to a run command tool embedded inside the field summary tool (which is a macro).  Errors were coming out when there was a space in the temp directory.  Our development team is set to address it in a future release.


I did take a quick look and noticed you have some special characters in your directory paths. You might want to try changing the paths to locations without spaces or special characters.


This error could mean a number of different things, so I might recommend posting this to a new thread since it is different than the issue on this thread. 




Jess Silveri
Premium Support Advisor | Alteryx

Hello JessicaS,


I'm also using a run command tool embedded inside the field summary tool and this error code: 1 is still appearing even though the Alteryx workflow completed successfully:

The Designer x64 reported: Error running Event #1: The external program "H:\Alteryx\Test Files\Moving_files.bat" returned an error code: 1: The operation completed successfully. (0)


I'd like to avoid changing the paths to locations without spaces if possible.  Has your development team made any progress in addressing this issue?








Alteryx Certified Partner



Any news on this? I am working with some file paths I cannot change to contain non-blanks.




Alteryx Certified Partner
Alteryx Certified Partner

Hello guys,


I did have the same problem. The way I solved it was to add the path between quotation marks (insteado of < D:\somwhere\here or there > to < "D:\somwhere\here or there" >.


If you are using dynamic variables you just have to put them in quotation marks too. Works too.



Alteryx Certified Partner



I had issues with ÆØÅ as well, which disturbed me a bit as well. All solved!


Has there been any progress on this issue? I am experiencing the same problem. Thanks!