community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
SOLVED

"Access denied" error in trial version non-admin install

Atom

Hi, new here!

 

I've tried to install the 14-day trial version of Alteryx Designer 2018.4, non-admin with "typical" options, on Windows 10 64 bit, and it appears to complete successfully. But on launching it I get

There was an error while loading: Unable to create temp directory lock file

C:\TempEngine_5252_40d68b6030914afbb715928e55e2aef8_.lock

Error: Access is denied. (5)

which makes sense - I don't have rights to create files (only folders) in the root of C:\. I can't get any further.

 

It seems like this would be a common situation for the non-admin install. What should I do?

Thanks!

 

@JoeP Alteryx is currently working on a fix. In the meantime, you can 1) Right click on alteryx and run as administrator 2) you/IT install the admin version of the product or 3) edit your environment variables. From the Windows start menu, you should be able to type environment and then select edit environment variables for your account. You would want to ensure there is \ at the end of both TMP and TEMP in your user variables (something like C:\Temp\).

 

1 and 2 above would require admin privileges/IT installation. 3 would not require admin privileges, but I'm not sure if there would be any unintended consequences with other programs that use those temp variables. I've done #3 on my computer and haven't run into any issues. @LisaL passed along #3 to me while they're working on fixing it. 

Alteryx
Alteryx
@JoeP  The Admin version of Designer does also show this behavior.  My current recommendations are numbers 1 and 3 in @patrick_digan 's post.
Atom

Thank you both! I've tried options 1 and 3 and both work.

 

Joe

Labels