Alteryx Designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
Don't forget to submit your entry for the Excellence Awards by October 30! | Need more information about the program? Check out the blog here

one module to execute another module

Highlighted
5 - Atom

@Aasishfkumar

 

Did you get any approach to solve the issue? I am also facing same issue.

Highlighted
7 - Meteor

Hello all,

 

Conditional Runners - great stuff.

 

I have a question that came up this morning when I did a short demo of Conditional Runners:

 

Say you have 2 Conditional Runners linked together so only if the first one runs a child workflow successfully then the 2nd Conditional Runner will run another Child workflow.

When you run such a routine it looks like the 2nd Conditional Runner starts to run before the 1st Conditional Runner has completed, rather than waiting for the 1st Conditional Runner to complete (see pic below).

 

If the workflow run by the 2nd Conditional Runner is dependant on some aspect of the workflow run by the 1st Conditional Runner (e.g the 1st loads data into a table that the 2nd will read from), but this 2nd Condtional Runner has already begun to run before the 1st Conditional Runner has completed, this could lead to errors.

 

Or is this "running" percentage status actually a pre-load of the referenced workflow into memory to then run when Conditional Runner 1 has completed?

 

One can have a Block Until Done tool between the success flow from Conditional Runner  1 and the input to Conditional Runner 2, or is this not needed?

 

Conditional Runner no.2 starts to run before Conditional Runner no.1 has completedConditional Runner no.2 starts to run before Conditional Runner no.1 has completed

I thought it would be good to check.

 

Thanks

 

 

Highlighted
13 - Pulsar
13 - Pulsar

I know this post is older, but I just ran across it.  Any idea why values 0 or 1 display in Alteryx as an "Error"?  I'd think that instead of the message being:

"Error: Designer x64: The Designer x64 reported: Error running Event #2: The external program "C:\Program Files\Alteryx\bin\AlteryxEngineCmd.exe" returned an error code: 1: The system could not find the environment option that was entered.
(203)"

 

Perhaps it would be better for values of 0 to just say "Success" and values of 1 to just say "Warning:...........".

 

Just curious.

Labels