Alteryx Designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
SOLVED

configure dropdow

L_Gordon
7 - Meteor

How can I configure a dropdown to have a user select a value and have that value added as a new field into a connected dataset?

8 REPLIES 8
AZuc
Alteryx
Alteryx

@L_Gordon , make the Action tool update a cell in a Text Input tool, then use Append Fields to create the column.

2o option: use a formula to create a column and use Action tool to update the formula

André Zuccatti

Sales Engineer - LATAM -
Alteryx, Inc.


L_Gordon
7 - Meteor

This is the workflow I want to use.  I don't need to input the year, I just want the user to enter a year and have a new field called Input_Year added.

AZuc
Alteryx
Alteryx

@L_Gordon 

 

Configure this way and it will work (make sure to remove the quotes at Replace specific string)

AZuc_0-1634936362450.png

 

André Zuccatti

Sales Engineer - LATAM -
Alteryx, Inc.


L_Gordon
7 - Meteor

It is not working, here is how I have connected the tools.

L_Gordon_0-1634937208178.png

 

AZuc
Alteryx
Alteryx

@L_Gordon try this

André Zuccatti

Sales Engineer - LATAM -
Alteryx, Inc.


L_Gordon
7 - Meteor

your workflow did not run for me.  We are on such an earlier version, 2020.1.5.25447 and that is probably the issue.  These tools in this application should not depend on the version, but that is probably my issue.

AZuc
Alteryx
Alteryx

@L_Gordon , please open the yxmz with a text editor, change the 2nd row, save and try again

<?xml version="1.0"?>
<AlteryxDocument yxmdVer="2021.3">

 

Change the 2nd row to 2020.1

André Zuccatti

Sales Engineer - LATAM -
Alteryx, Inc.


L_Gordon
7 - Meteor

I apologize profusely.  Your solutions were 100% helpful and I will accept them.  I forgot that when you run the workflow as an App, the calculations are correct, but you can not see the intermediate values of the tools.  In this case, I was just testing how to open multiple files without having to use the folder selection tool, as that tool does not work on server.  I could see the results in debug mode.  So thank you for your help.

Labels