Alteryx Designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
SOLVED

XML Parse Stopped Working in 2020.4, But Works in 2020.3

hellyars
12 - Quasar

Did something change with the Parse Tool?   I have dozens of workflows that just error out now at the first parse.   The source docs are static, so they did not change. 

 

  1. Source is XML
  2. Input tool set to Return Root Element, Return Child and Return Outer XML
  3. Second Tool = XML Parse Tool set to Root Elment OuterXML, Specific Child Name, Return Child Values and Return Outer XML.

This approach has worked for 3 years.  Now it just stopped.

5 REPLIES 5
AngelosPachis
15 - Aurora

Hi @hellyars ,

 

It appears that this is probably a bug if you are on 2020.4. I heard other users raising that issue, not sure if there has been an update in the tool or something happens with Designer but you can report it on alteryx support as well.

hellyars
12 - Quasar

@AngelosPachis 

 

This looks to be a 2020.4 issue.  I just downgraded to 2020.3 and everything works again.  

AngelosPachis
15 - Aurora

Thanks for confirming this @hellyars ,

 

Hopefully when this bug gets fixed you can move back up to 2020.4

 

Cheers,

 

Angelos

CKS
5 - Atom

Hi, Did you get any solution on this problem in version 2020.4?

I am also facing same challenge after the recent update from 2020.3 to 2020.4.

ntobon
Alteryx
Alteryx

@AngelosPachis @hellyars  @CKS 

You are running into a known Defect: DE28334 - In version 2020.4 the XML Parse tool does not detect specific child.
WORKAROUND : Use Formula to remove any single letter and a following colon from tags from the DownloadData field.
Expressions:
REGEX_Replace([DownloadData], "<\D:", "<")
REGEX_Replace([DownloadData], "</\D:", "</")
Please apply the workaround.

 

Check this article: https://community.alteryx.com/t5/Alteryx-Designer-Knowledge-Base/XML-Parse-tool-does-not-detect-spec...

Labels