community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
#SANTALYTICS

Gather all 9 clues to complete the final Weekly Challenge on Dec 16!

Learn More
SOLVED

Writing data from SQL Server to Snowflake

Atom

Hi Guys ,

I hope someone would be willing to help i am currently learning alteryx as we are using that in conjunction with tableau and snowflake to create our Dashboards.

I am however stumped and i have tried to find resources to no avail .

I want to upload data to snowflake using alteryx

I am extracting data from a table from my database (Which works ) however the upload part to snowflake is where the problem is occurring i have tested the connection so that is not the issue .

So has anyone wrote data to snowflake from a MSQL table using alteryx ? If so

Please help 

 

 

Alteryx Certified Partner

Hey @Shiven27 

 

I'm doing this very process right now, what is the issue that you are having?

Atom

Hi @LordNeilLord

 

Well the Issue is I keep getting errors when trying to write the data to a table in snowflake 

 

I am reading data from my sql server database which I am able to do 

 

Thereafter I ouput to snowflake I am new to alteryx so I do not understand what specific steps I need to take 

 

I have attached my workflow and output configuration .

 

Thank you so much for you assistance 

 
 
Alteryx Certified Partner

Hey @Shiven27 

 

Have you got a screen shot of the error?

Highlighted
Atom

Hi I have attached the error as a txt file . 

 

I was wondering if I need to map the data some sort of way as you would in ssis ?

 

Or must I create a table on snowflake first and then import the data from sql Server . 

 

Because snowflake data types are different compared to sql data types .

Alteryx Certified Partner

Hey @Shiven27 

 

This is the error: 

 

"TotalOfTransactions" NUMBER(39, 2)

 

I presume this is being defaulted as a fixed decimal (39, 2) which is too big for Snowflake.

 

If you put a select tool before the output and change this column to be a fixed decimal of 38,2 this should solve your issue

Atom

Thank you so much @LordNeilLord that worked 100% I really do appreciate it .

On that note would you suggest any blogs or material that I could use to upskill in alteryx

Labels