community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

Workflow truncates table on schedule, runs fine manually (server)

Asteroid

Hey Everyone,

 

I seem to have a strange situation I can't figure out. I have a somewhat complex workflow that grabs data from multiple locations, does a lot of transformations, and outputs the data into 2 tsql tables (using delete and append). The issue is that when I schedule this job on the server, it runs but truncates the tables, so no data.

 

When I troubleshoot this by running the EXACT same workflow manually (also on the server), it runs totally fine and loads the tables as expected. Note that I've tried multiple schedule times over the course of several days - all end in the same result (truncation). Any ideas as to why this is? The scheduled jobs don't look to be returning an error so it's difficult to troubleshoot.

 

Thanks in advance

Pulsar
Pulsar

For me, when this has happened, it's because the Server doesn't have access to the tables.  I have access, and when I'm logged onto the Server, and running things in Designer, the database sees me as the user, so all is good.  But when the Scheduler runs it, it sees the Server as the user which does not have access.  The Server will need to get a generic account, or you can always change the Server Settings to "Run As" you.  Not sure if that's the same reason for your issue, but it was for mine.

Highlighted
Asteroid

Thanks, that definitely makes sense. I ran the workflow on the scheduler one time today during business hours (as opposed to overnight), and it did load (same workflow). So I'm thinking it could be some sort of network issue within my organization. Anyways I have it on a later in the day schedule now rather than overnight, so I'll see how that goes. 

Labels