community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

Workflow runs in designer, but errors out with "unknown variable" in gallery

Meteor

My workflow runs without a problem.

 

Then when you publish it to the gallery, it says that the [ShipTo Contact] variable is missing in a formula.

 

clipboard_image_0.jpeg

The formula is pretty simple

If !IsNull([ShipTo Contact]) Then TitleCase([ShipTo Contact])

ELSEIF !IsNull([Contact name]) Then TitleCase([Contact name])
ELSE 'Valued Customer'
ENDIF

 

And the metadata shows that the field exists.

 

clipboard_image_1.png

 

Any ideas what the problem might be?

 

Alteryx
Alteryx

Is the variable dynamically created?

It may be worth running the workflow itself, as the validation may be missing the fact the variable is created further down the line.

Meteor

The variable is not dynamically created or altered in any way.  It comes in the same format from the original data source.  The workflow itself runs with no errors in Designer.  It is only when I publish it in the Gallery that there is the error.

Alteryx Certified Partner

Hi @harvjul ,

 

Is the original data source that contains the variable accessible in it's location by the server? If you have not packaged the data with the workflow when you uploaded it, then the server workflow is trying to access that original data source, and if that is, for example, stored locally on your PC then it won't be able to read it, and the variable will therefore not exist.

Worth checking.

 

M.

Alteryx
Alteryx

Hi @harvjul 

 

Sorry, I meant if you were to log into the Gallery itself and run it, do you still get the error, or is it only when you save/upload it to the server it errors?

Meteor

All 3 files that are read in are stored on a network drive that is accessible by the Alteryx server.  The first 2 files are ready in successfully without a problem.  This third file appears to be read in, but doesn't have the error until the middle of the workflow.

Meteor

When you run the app on the intranet local gallery site, the same error occurs.  Is that what you mean by login and run the app?

 

clipboard_image_0.png

Alteryx
Alteryx

This does sound a little odd. Are you able to remote onto the Server itself and run it in designer on there? 

 

That may be the best way to get the final clues as to what's going on.

Meteor

I did a force rename with a Select tool and then did a multi field formula with [_Current Field_] as the formula.  That did it!!  Now it runs successfully.  Root cause of why it didn't work before is not understood, but at least it is published successfully.

Alteryx
Alteryx

Does sound odd that that's the fix. A big part of me wants to get to the bottom of it, are you able to upload the workflow for us to take a look?

 

If you want to just move on though, I understand

Labels