community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
Community v19.6

Looks aren't everything... But the latest Community refresh looks darn good!

Learn More
SOLVED

Workflow Scheduling

Could anybody help me on this error. I tried scheduling a workflow but I keep getting this error and am not sure how to fix the problem. I do not have server.Capture.PNG

 

 

 

Moderator
Moderator

Hello bobokoko1,

 

By default, the scheduler runs as a local system account, which may not have access to the folder the macro is contained in. I recommend exporting your workflow as a .yxzp file, and then scheduling the .yxzp package using the schedule manager window.

 

Check out the following resources which should help out in this situation.

 

https://help.alteryx.com/current/index.htm#ScheduleNewJob.htm?Highlight="schedule to my computer"

https://help.alteryx.com/current/ViewSchedule.htm#SchedulePackage

 

Mike

Mike Spoula
Solutions Architect - Services
Alteryx
Aurora
Aurora

Hey @bobokoko1

 

Did you manage to solve this one, server identity & security context can be fairly tough.

 

The other thing you need to do is work with your server admin team to make sure that any data connections you need for this flow are set up on the server.

Let me know if you've managed to get to a solution (or just mark this thread as solved with the green "Solution" button) - or if you're still struggling let's iterate together to get you there?

 

cheers

Sean

Asteroid

Are you running as a local user or you running an alias.  You need to make sure that if you are running with an alias, that your alias has access to "GoogleSheetsInput"

 

Sorry for the delayed response, it looks like that work, but now I'm getting error:. I changed my settings to run as, but I am not sure what to do now. Capture.PNG

Highlighted
ACE Emeritus
ACE Emeritus

it looks like the machine that you scheduled the workflow on does not have a mapped drive for "F:" on it.

 

Instead of using mapped drives (F: G: H;) you can switch to using UNC paths for your output / input.   That likely will fix the problem you are seeing bove.

Thank you, this works great. 

Labels