Alteryx Designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
SOLVED

What is the status of the AMP engine vulnerability?

Dan5
8 - Asteroid

There is a note at the top of this page: https://help.alteryx.com/20214/designer/alteryx-amp-engine

 

Stating to not use AMP. I am curious to know what specifically is wrong, and when it will be resolved?

3 REPLIES 3
gaustin
Alteryx
Alteryx

In accordance to security best practices, Alteryx is not disclosing specifics of the vulnerability until all supported versions are updated with a fix.  These releases will start being available this month, continuing through May.

CharlieS
17 - Castor
17 - Castor

That AMP page was last updated February 2nd and Designer 2021.4.2 was re-released on March 16th, I assume they addressed that issue and re-released, but this might be a good email for support@alteryx.com to get confirmation. 

TonyaS
Alteryx
Alteryx

This vulnerability has been fixed in all prior supported versions and details were updated on Release Notes pages. 

Tonya Smith
Sr. Technical Product Manager, Alteryx Engines
Labels