community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
Upgrade Alteryx Designer in 10 Steps

Debating whether or not to upgrade to the latest version of Alteryx Designer?

LEARN MORE

Web Link Without Underscore

Atom

Good Afternoon,

 

My workflow will generate a table and in one column, I have the need to display a simple text string or display a URL.  For example, let’s say I have a column called “MESSAGE”.  The first row of data might say “Alteryx is great” and the second row might be a link to your website.

 

If I get “Alteryx is great” to display properly, then the code behind the URL displays as a text string. 

 

Using Tara’s article “Web Links in Reports (https://community.alteryx.com/t5/Engine-Works-Blog/Web-Links-in-Reports/ba-p/1904) as a guide, I was able to get close to my desired output.  I build my URL up stream in a formula:

IF condition

THEN '<a href="' + [URL_LINK] + '">' + [MESSAGE] + '</a>'

ELSE '<a href="#" onclick="return false;">' + [MESSAGE] + '</a>'

ENDIF

With the above, the URL looks proper and works correctly.  However, “Alteryx is great” will display with the web-link underscore and I would prefer not to have that line there.

 

I tried using style="text-decoration:none;" with no luck.  I can change other attributes like the font color, but cannot shut of the underscore.

 

In addition to a possible solution from you, I have some related questions…

  1. Both of the following lines appear to deliver the same working results. What does the “:A” do or mean?

<a href="[URL:A]">[SiteName:A]</a>

<a href="[URL]">[SiteName]</a>

  1. Why will some attribute settings work in Alteryx, but the "text-decoration:none;" does not.

<a style="text-decoration:none;" href="[URL]">[SiteName]</a>

 

Thank you,

Mike

Highlighted
Alteryx Partner

So you're creating all the URLs and alt text in Alteryx and creating the HTML properly, but what sort of file are you writing to and how are you viewing that ?

 

The "text-decoration:none" as a CSS attribute is the right answer, but when you're viewing the output the CSS is being ignored.by that program

Atom

My target output is email.  Email and Render are giving me the same result.

Alteryx Partner

Understood, but it's your email client that is ignoring the CSS.  There might not be anything you can do about it.

 

Is it internal email ?

What email client do you use ?

Labels