Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
Check out our powerful new search update! You can read more here. Please let us know if you have any feedback by creating a topic here.
SOLVED

Warning: ... There is no Question corresponding to the specified App/Macro value "Input...

Highlighted
Alteryx Partner

Hi!

 

When I run a workflow with inserted an own macro I get the warning:

 

Warning: ... There is no Question corresponding to the specified App/Macro value "Input...".  The App/Macro may be out of date.

 

 

I have changed in the develop macro the Macro Input Tool configuration from File Input to Text Input and deselect the Show Field Map option

 

What is the meaning of the warning!

 

Mathias

 

 

Highlighted
Alteryx Certified Partner
Alteryx Certified Partner

I've never seen this error before, could you post the workflow so I can have a look?

 

Ben

Highlighted
Alteryx Partner

Hi!

 

Thank you for your support.

I can't give you a workarroud when the warning appear.

My steps:

I insert the macro to a workflow and save the workflow. Always work fine.

The next day a open the workflow with the macro include. The warning appear.

Than I delete the macro and insert the macro again. The warning disappear, mmh. busy I know.

 

Now I don't see this warning any more.

So it is difficult to have a look on it and make a statement. When you never have seen this warning before.

 

Mathias

 

 

Alteryx Partner

Hi!

 

I get support from Aleryx Support Team Paul Noire.

The warning occur when I connect a macro with an Macro Input Field >> Text Input. When I run the workflow sometimes Alteryx did not know witch data type has been chosen. The workarround is to connect a Select Tool between the connection. The Select Tool selected the right data types.

 

Highlighted
Meteoroid

Hi If not already figured out - Just Open the yxmc file and look for your node number and delete the whole node section. I had same error with node 97 and deleted below section and saved - I recovered the file.

 

Hope this helps!

 

<Node ToolID="97">
<GuiSettings Plugin="AlteryxBasePluginsGui.MacroInput.MacroInput">
<Position x="306.0001" y="485.0003" />
</GuiSettings>
<Properties>
<Configuration>
<UseFileInput value="False" />
<Name>Mystuff</Name>
<Abbrev />
<ShowFieldMap value="False" />
<Optional value="True" />
<TextInput>
<Configuration>
<NumRows value="1" />
<Fields>
<Field name="Mystuff" />
</Fields>
<Data>
<r>
<c>mylinkforshowonly</c>
</r>
</Data>
</Configuration>
</TextInput>
</Configuration>
<Annotation DisplayMode="0">
<Name />
<DefaultAnnotationText />
<Left value="True" />
</Annotation>
<MetaInfo connection="Output">
<RecordInfo>
<Field name="Mystuff" size="57" source="TextInput:" type="String" />
</RecordInfo>
</MetaInfo>
</Properties>
<EngineSettings EngineDll="AlteryxBasePluginsEngine.dll" EngineDllEntryPoint="AlteryxMacroInput" />
</Node>

Labels