Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

Version 2020.1.2 has broken only unique macro

7 - Meteor

I've downloaded the non-admin version of Alteryx 2020.1.2, so now I have both Alteryx 2018.4 and 2020.1.3. 

However BOTH versions do not work with the Only Unique Marco in my workflow. 


It is quite inconvenient to have my whole workflow broken and, judging by the comments, appears to happen at every major update. 


What is going on? Will deleting v2020 fix this? (problematic because I have already worked on other workflows which are now saved as the new version, and I believe will no longer open with the 2018 version). 

Do I need to re-do the macro? A huge waste of my time as I have used multiple copies and I haven't written down the exact settings of each so will need to think it through for each of them.


Can I fix this in any other way. Any help will be great. 

Will copying the Only Unique files to specific file location help?


Alteryx can you please add an option to your duplicate tool so that you can output all duplicated lines, so that I don't need to rely on breakable third party elements for basic functions.

Can you design updates that leave the original version in normal working order so I can test the new version of Alteryx without breaking the old version.


Many thanks. 

12 - Quasar
12 - Quasar

Maybe when you created the macro it was built with the older version.


You can change the version of your Macro File or Workflow with the help of this post and try again.

17 - Castor
17 - Castor

Hi @ChrissD 


Can post an image of what you mean by "Broken"



7 - Meteor

Further information about this issue 

When I opened the workflow it said: 

This workflow references macros (C:\Users\[etc]\Downloads\Only-Unique\CReW_OnlyUnique.yxmc) that are missing or inaccessible. Saving this workflow will permanently disable these tools (obviously I made a bunch of copies of the workflow before I went any further).


However no files were moved since the last time I ran the workflow. Do you think the update reset the file path to the default? 


This is what a broken macro looks like in the workflow. 

You can see that all outgoing connections have been deleted, so the workflow does not work at all.

Missing macros 2.JPG

Good news: 

If you click on the black shape, it provides the following information, listing the fields that had been selected, so I was able remake each shape with a reminder of what I was doing with each shape. 

Missing macros 3.JPG

7 - Meteor

I've since copied the macro into my download folder. The workflow then had no problem using the macro.Then I popped the macro into another folder inside the download folder. The workflow then could not use the macro.Took the macro back out into the download folder. Workflow was fine. 


Basically the update must have re-written the file path my workflow was using from the proper file location to my download folder. 

I do not keep useful files in my download folder. This change makes no sense. 


I don't think it's right that updating to the new version of alteryx should re-write the file location that my workflows use to look for macros. 


I've raised this with Alteryx Support, Case #00335438


So the short term fix is to copy your macros into the file location specified in the error window when opening the workflow. 


Hi Christine 


If you package the workflow to includes all macro's, this should open the workflow and reference the macro correctly. The following article provides information on this


Further testing is require to confirm if the path changes for macros dependent workflows.


Kind Regards