community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
SOLVED

User interface input multiple values

Hi all,

 

I can't seem to find a solution anywhere but here's what I'm after

 

I have ~3 million records in a yxdb table that I've created and now I'm trying to create an app for the business that allows a user to input and return the fields for 1, many, or all primary key values (let's call it item_no). Essentially i need the business to be able to paste in a list of values and return all relevant information from my 3million record table.

 

I've tried several ways to do this via in statements/filters, creating new data inputs and keep coming up empty. 

 

Any direction would be much appreciated

 

Thanks in advance!

 

5-1-2017 10-35-22 AM.jpg

Nebula
Nebula

I know that this is a nasty way round, but you could do this very quickly by letting them put the relevant values in a spreadsheet.   The benefit of this is that time-to-value is pretty much zero (you could do this in seconds)

 

 

Cleaner would be to create a simple macro that gives them a plain text input box which they can ; delimit the primary keys, and then pump this out to a YXDB once you've cleaned it up, and then use that to join?

 

By separating this out into a specific macro, you can do all the error checking and control the complexity possibly a little easier?

This should work

Product App.JPG

Nebula
Nebula

Hey @SVERHEYDEN - did either of the replies help?

Alteryx Certified Partner

Hi @SVERHEYDEN,

I would recommend avoiding free text altogether because users can introduce errors. There is a neat way of creating a list of the values that are found within a field and allowing the user to select from those described in option 2 in the following knowledge article: https://community.alteryx.com/t5/Alteryx-Knowledge-Base/Dynamically-Create-List-Box-Values-From-Inpu...

Let me know how it goes!

Cheers,

Sasha

Thanks Sean!

 

Now I'll just add another another detour that allows the user to input a file and we're there!

Hi, was wondering if I could add a 3rd radio button for a file selection option?

Hi. Here is what my workflow/app ended up as

 

The part that wasn't very intuitive was that I needed a placeholder file just to get it to work. Maybe there's an easier way but it worked for meworkflow.png

Highlighted

Thanks a lot. It helped

Meteor

Hi rohanonline,

 

I recreated your worflow, but instead of having that Browse tool, I put an output tool since i would ultimately like it to render to a nice formatted table... However, when I do that, it only outputs the first record I entered. Even if I use the semicolon to separate my records, it only outputs the first record... I modified your workflow by replacing the browse tool with an output tool, and it looks like you run into the same issue. Any idea how to fix that so I can output to an excel file with the multiple records that my user specifies?

Labels