community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
SOLVED

User Cancelled error Issue

Highlighted
Meteoroid

Curious if anyone else experiences this.  It seems like about 1 out of every 10 times I run a workflow, the workflow will hang for a period of about 5-10 seconds and then throw the following error:

 

Error: Designer x64: The Designer x64 reported: AlteryxProcessManager::Start: User Canceled

 

This would indicate that I am cancelling the workflow but it has happened enough where I know it is not user error double clicking the run button and therefore cancelling it.  I can't seem to nail down a cause.

 

The issue never occurs twice in a row so I simply just rerun the workflow and it works normally.  It's not a big deal but still an annoyance especially when I hit the run button on a workflow that takes 5-10 minutes and leave my desk only to come back to a cancelled workflow.  I also investigated a possible network glitch but that isn't the case, the error still occurs at the same frequency whether I am hardwired in to the network or connected over WIFI/VPN.  

 

For reference, I am using 64-bit on version 11,3,2,29874

 

Any help would be much appreciated.

Quasar
Quasar

Are you using the Download tool? 

 

I have only had interment issues with workflows hanging that use the download tool. Sometimes hangs for no apparent reason, but works fine on next run with no changes.

 

I have not experienced a hang on a workflow that does not use the Download tool.

Meteoroid

No, I rarely use the download tool.  I do have some connections to sharepoint that have not been very reliable but it's not limited to just sharepoint connections.  The majority of my workflows are connecting to files on network drives so usually the first tool to run is the Directory tool

Meteor

I'm seeing the error as well. Randomly Alteryx will run for around 30 seconds and return the User Cancelled error message. I'm on 11,3,2,29874 also. No download tools, I typically have a Teradata SQL connection in an input tool.

 

Start: Designer x64: Started running at 8/11/2017 11:57:43 AM
Error: Designer x64: The Designer x64 reported: AlteryxProcessManager::Start: User Canceled
End: Designer x64: Finished running in 30.4 seconds with 1 error

Moderator
Moderator

@toddhowl and @ctthornb - as this likely requires a more in-depth look at your Alteryx configurations, please reach out to support@alteryx.com and we would be happy to assist further

 

Best,

 

 

Sophia Fraticelli
Customer Support Engineer
Alteryx, Inc.
Atom

Could you please advise if support has solved this, and share any details? We are experiencing the exact same 30 second error message and UI freezing. Thanks!

Our whole team of ~20 people are experiencing the same issue.  Were you able to find a resolution?

Meteoroid

No, I haven't been able to.  

 

Workaround for us:

We only have desktop licenses so we don't have a scheduler option but our workaround is that we take advantage of the List Runner and Log Parser in the Crew Macro pack to run batches of workflows at a time.  We have a filter that looks for this specific error in the output of the log parser and if it finds that error, we send the failed workflows back through the list runner again.  It always works on the second time.

 

We haven't found a fix to when it happens when working in a single workflow...I just have been dealing with it and rerunning as needed.

 

 

@ctthornb @jennifercook  @stevea1 @toddhowl

What you're seeing is a known bug.  It has to do with a temp file not being cleared fast enough between runs. I sent it in to Alteryx on the release of 11.0 and had one of the engineers check out my machine at Inspire to confirm it was still there in 11.3.

If you want to avoid the issue completely you'll have to downgrade to 10.6 or possibly upgrade your hardware.  I can reproduce it consistently on machines with CPU's < 2.7 GHz.  Laptops especially.

Alteryx
Alteryx

Just as @SophiaF mentioned above, you can contact support@alteryx.com for more personalized, in-depth assistance. 

 

@ctthornb @jennifercook  @stevea1 @toddhowl

One thing that has helped some other customers was to have their IT specialists look into their security software configuration: sometimes the security software needs to grant Alteryx elevated rights, and if the granting of these rights is delayed, then the result is that the workflow times out.  In one case, in particular, the security software was configured so that dual profiles were exacerbating the situation.

Labels