community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
SOLVED

Use Formula with my own parameter get from a Textbox tool

Alteryx Partner

Hey !

How is it possibly to work with parmeter from entry fields?
Given:

Text Box tool connect to a an Action tool and connect to a Formula tool
Input data tool (with a select * from mytable) connect to the Formula tool.

When I run the workflow I get the error:  

Formula (24)    Parse Error at char(20): Unknown variable "myentryfieldtext" (Expression #1)

How configure my Formula tool and my Action Tool?

 

Mathias

 

My current configure:

Text Box

 

 

Action Tool

Formula

Alteryx Certified Partner

Hey Mathias,

In your formula you are trying to find the field called myentryfieldtext, this doesn't exist in you data set. What you need to do is surround it in quotes ("myentryfieldtext") then it will be recognised as a string. Once you do that then the updating action you are doing should work.

Alteryx Partner

O.K thanks it works.

One Question at once:

When I connect a Browsetool at last I get not the right output.

 

When I use a Output Data tool an write the output into a csv-file. I get the correct output.

 

Why?

 

Mathias

Alteryx Certified Partner

I'm not sure why you would get different answers between the browse tool and the csv output without actually seeing what is happening and what is going wrong.

Alteryx Partner

Hey Paul!

 

I will you descripe what is going wrong:

1. my workflow

workfollow_formulaexamle.PNG

 

 

The formula expression is result = Contains([vorname], "mytext")

I start run as analytic app with the input parameter: mytext := Matt from the Textbox tool

2. output csv-file

workfollow_formulaexamle_output_csv_1.PNG

3. output browse tool

workfollow_formulaexamle_output_browsetool_1.PNG

 

You see the diffrence between output csv an output Browse tool?

I did not understand why the diffferent output was generate.

 

Mathias

 

 

 

 

Alteryx Certified Partner

Matthias,

 

I couldn't replicate your error. I have a question though, what are the select tools doing?

 

I set up the formula tool to create the Result field as a Boolean and it worked fine to both the Browse and the csv. The only thing that I can think of is that the Result field is becoming a Boolean after the split and or something funny like that. Try having one Select tool go to both outputs. Otherwise, if the select tools just remove fields, then put one select tool before the formula tool and have everything performed in the formula tool.

 

Kane

Alteryx Partner

Kane,

 

I have you attach my workflow with required data in a Text Input tool.

Now you can take a look on it.

I only get always the similar output as I have post.

 

Mathias

Alteryx Certified Partner

Hi Matthias,

 

The browse tool in the canvas will always have false when you hit the green start button as it is looking for "mytext" in the name. When you run it as an app, the correct text replaces "mytext" and so you get the expected results.

 

To test the browse against the output tool, select the browse tool in the interface designer and then it will appear on the output of your app for you to look at.

 

Kane

Alteryx Partner

Hi Kane,

 

thanks for your supprt.

I get the same output results too.

 

It is not possible browse tool and other tools required for an app work together by running workflow only.

In is only works correctly by running as app.

 

mmh...

 

I mean, it's like this

 

Mathias

 

Labels