Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

The highly anticipated Alteryx Community tradition is back! We hope you'll join us!

Learn More

Union tool input not initialized


Hi all,

I'm using the union tool in one of my workflows, and from time to time I will get an error saying "Internal Error: The input "#2" was not initialized."


This error happens when there is no data flowing in on one of the connections, is there any way to prevent this error? There are times when data will only flow from 1 connection, and other times it will flow in from both.  What's the best way to resolve this?

Alteryx Certified Partner
Alteryx Certified Partner



When I've seen this, I am using a detour and not pushing any data to the UNION.  If I use a SELECT RECORDS with a value of 0 or use any method that doesn't push a record, but still creates the metadata for the record stream, the issue goes away.  It sounds like you have no data flowing, rather than 0 records.  If you can force metadata into the connection, this should go away.




Alteryx ACE & Top Community Contributor

Chaos reigns within. Repent, reflect and reboot. Order shall return.


On the following workflow the outlook input tool is not initializing and i dont really understand why. Can you help?




@MarqueeCrew - I also have the metadata issue with the outlook tool. Do you have a workaround for this too?


My workaround is to create a separate workflow which reads the outlook into a separate file then combine the new file with your other input file. The issue I now have is that when i run the new workflow the input tool combines my columns into one even though i have defined the comma as the delimiter. Why?


DateTimeReceived and Subject should be two separate columns!


I place a Select Tool at the end of each stream that feeds into the Join tool. I also place a Block Until done tool prior to each stream that feeds the Join with #1 row in the Join connected to #1 on the Block Until Done and #2 row in the Join Tool connected to the #2 connector on the Block Until Done tool.


Hi, I am really stuck on the same problem - do you have an example of your solution?


I can't get my union to work when one of my detours is not selected. Alteryx simply won't ignore the union, but go on to say there were no outputs?


Any ideas? any solution would be much appreciated




Alteryx Certified Partner
Alteryx Certified Partner

Can we please see a screenshot of your workflow.




Hi Ben - please see attached.

if I run the app and just tick A & B the result will be 'There were no outputs' 

If I tick all three it will result in an output.

I want to be able to just ignore the union if C is not selected and continue to Union A & B (or any other combination).


FYI  the text inputs just contain one column 'Test' and one cell of data underneath - A, B or C respectively for each text input  


Hope that helps explain the problem?


Thanks for helping


anyone able to help?