Alteryx Designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

General Discussions has some can't miss conversations going on right now! From conversations about automation to sharing your favorite Alteryx memes, there's something for everyone. Make it part of your community routine!


Unable to resolve Oracle Instant Client Error Issue (Oracle Drivers)

7 - Meteor

I've had multiple issues with my new computer with Oracle drivers. Initially, I couldn't find the driver so I had to use the manual technique or the first screenshot below to connect to Oracle. 


The issue resurfaced, and when I tried to use the method again, I get the error on the 2nd screenshot. 


This could be the issue cause by installing both 32-bit and 64-bit drivers on my PC. But I've gone through so many topics online with regards to the same issue but can't seem to resolve it. I've downloaded multiple Drivers from oracle and tried to install them. But they don't seem to install cause I already have (maybe) the required Oracle drivers. 


Anyone with new ideas?  







15 - Aurora
15 - Aurora

Hello @Gana_Baliada,


you say you have installed multiple oracle client versions? Try to install one above 12.1 Then afterwards go and look for the following file:


C:Users\<USERNAME>\AppData\Roaming\Alteryx\Engine\<ALTERYX VERSION>\UserSettings.xml


There you need to look for the following line and put your oracle client path:


<OracleInstantClientInstallPath NoInherit="False">C:\ProgramData\instantclient_12_1\</OracleInstantClientInstallPath>


This is just an example, look for your path.


This should solve your issue