community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

Unable to read Oracle data - ORA-22835

Highlighted
Atom

Hi,

I am having an issue to get data from ORACLE and it seems the problem is related when i want to read specific columns.

 

I tried to limit the length of the column by using Select SUBSTR (Column_Name, 1,4000) From Table_name  but i am still getting the same error.

 

Alteryx Error.PNG 

Any ideas/suggestions on how to solve this is welcomed.

 

Cheers,

Luan

 

 

 

Alteryx Certified Partner
Alteryx Certified Partner

@luan_i,

 

If the data in the column is an Oracle Large OBject (LOB), you might need to use DBMS_LOB to access the data (http://docs.oracle.com/cd/B19306_01/appdev.102/b14258/d_lob.htm#BABDDFDH) to convert CLOB to CHAR or BLOB to RAW.  I've googled several articles (search:  Oracle ora22835).  I believe that this challenge is with Oracle rather than with use of Alteryx.

 

I did get to read some interesting posts in their community.  One that caught my eye was:

 

How do you expect anyone to be able to help you if you don't post any information about what you are doing?

 

Wow!  How helpful was that person?

 

Cheers,

Mark

Alteryx ACE & Top Community Contributor

Chaos reigns within. Repent, reflect and reboot. Order shall return.
Labels