Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

Unable to pass SQL Query as parameter in app workflow through cmd prompt

Highlighted
Meteoroid

Hi Team

 

I've created a workflow to accept database connection and SQL Query dynamically through command prompt and print output to a csv file
getting created dynamically.

 

Initially I've given connections and wrote a simple query in the workflow.

 

When tried to run the workflow from cmd prompt with different parameters of SQL query , workflow is executing with the query initially
given.

 

However , output file is working fine as results are written to new file everytime.

 

Sample workflow is attached and the cmd used as is follows:

 

AlteryxEngineCmd.exe "<WizardValues ShowDebugMessages='False'><Module>C:\Users\ynijapuram001\Desktop\FAAST\dynamicinput.yxwz</Module><Value name="File Browse (5)">odb:Provider=SQLOLEDB.1;Integrated Security=SSPI;Persist Security Info=False;Initial Catalog=PROJECT_FUTURE2;Data Source=MATLKADV2SQP003,14330;Use Procedure for Prepare=1;Auto Translate=True;Packet Size=4096;Workstation ID=YNIJAPURAM00151;Use Encryption for Data=False;Tag with column collation when possible=False|SELECT * FROM information_schema.tables where table_type like '%TABLE%'</Value> <Value name='File Browse (7)'>C:\Users\ynijapuram001\Desktop\procoutput.csv</Value></WizardValues>"

 

 

I tried changing sql query and executed the workflow but I can see the results are fetched from initial query but not the latest query :

 

SELECT * FROM information_schema.tables where table_type like '%TABLE%'

 

sql query issue.GIF

 

 

 

 

 

Labels