Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

Unable to edit Server Data Source - Unknow Error. FormatException


If I go into the admin section, data connections, click on my SQL database, whenever I try and change this:


odbc:DRIVER={SQL Server Native Client 11.0};UID=SQL_DBO;PWD=__EncPwd1__;DATABASE=;


to this:

odbc:DRIVER={SQL Server Native Client 11.0};UID=SQL_DBO;PWD=__EncPwd1__;DATABASE=COMMON;


I use my real server name and replace __EndPwd1__ with the actual values, I get this error:




The new DSN string matches exactly what I have in Designer on my computer, so I doubt it's a format issue.  If I delete the data source and recreate it with the exact same name, what will happen to any workflow that uses this connection? Will they fail because the data source has been deleted, or will it just use the newly created version?


@adm510 Can you advise what version your server is running. I was unable to reproduce this error on 11.3.x. As a note Gallery connection utilize a unique ID number in the background that ties the alias to information in the servers database. Deleting and recreating the connection will create a new DB entry with a new unique ID. Because of this any workflows using the previous alias (even with the exact same name) will fail because the database entry for that alias no longer exists. Correcting this should be as simple as selecting the new alias though.


I am using v11.0, I can't seem where to find my specific version # beyond that.


@adm510 I did some additional testing on and was also unable to reproduce the issue. My best guess is that there is an issue with your particular Data Connection, the connection string does have a format error (looks fine from what you posted but check it for extra white space or non-printable characters to be sure), or your server is running an early version of 11.0 that has an undocumented issue effecting this behavior.

In regard to checking the version you can open Designer on any workstation or server and go to Help > About to get the full version number. You can also check the server version by connecting to Gallery. At the bottom of the page is a "LOOKING FOR MORE?" link/button. Click on it then click on "Version".


I'm receiving the same issue on a server that was 11.3 and the issue continues after upgrading to 11.7.


I would like to note that the connections I'm having issues with are using the newer Teradata drivers, which have spaces in the names (Teradata Database ODBC Driver ##.##). I'm not sure if whitespace is a no-no, but it works fine on the initial input and it works fine in Designer; I just can't modify them through the Gallery.


We are experiencing the same issue, so this is clearly a bug.  We get the problem when trying to edit a SQL Server data connection.  I am trying to amend the server name to a new DNS alias.  After getting the same message as you, I tried to create a new connection with the same connection string and it worked fine, so not a problem with the connection credentials.


I have raised a support ticket.

Alteryx Partner

We also have the issue in 11.7.4, support has confirmed the bug:


The unknown error format exception is an issue we are aware of that happens when you try to edit any connection on the Gallery under "others" category. 

If you have this issue when editing the workaround is to create a new connection.


@spainn and @KevinP


Any updates on the support ticket, or where could I look to find it?


I'm facing this issue in Server 2018.2 today when trying to update a data connection saved in the server with the new password. Like others, nothing changes except the password, and recreating the connection a second time works just fine, so it's only modifying the connection that is the issue.