Inspire EMEA 2022 On-Demand is live! Watch now, and be sure to save the date for Inspire 2023 in Las Vegas next May.

Alteryx Designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer and Intelligence Suite.

Unable to do a clean uninstall needed for upgrade

5 - Atom

I wanted to get on to the latest Alteryx designer and the install pack needed me to uninstall any previously installed package. Now the only thing left is "Alteryx 11.0 x64 (Remove only)" and I am unable to remove it. So the new designer install fails every time. Does anyone know how I can get rid of old Alteryx and do a clean install of Alteryx designer.

5 - Atom

For now I have gone with installing a NonAdmin version which allows for multiple instances of Alteryx installs. Would still like to know how to do a cleanup of older version.

Alteryx Alumni (Retired)

Have you tried uninstalling from the Control Panel?

5 - Atom

Are you having trouble with the R package or just the Designer? 

And did you try and uninstall from the Control Panel (Uninstall programs)?

5 - Atom

Having the same issue. When trying to uninstall (the "remove only" part left) via Windows add/remove thing, the uninstaller results in "fatal error during installation. please check your settings and try again"

7 - Meteor

Going to add my name to this list as well - I have tried uninstalling via the Uninstall Alteryx file in the Alteryx folder, and through the control panel. Either way, the uninstall process just hangs up - it doesn't freeze or error out, it just churns away without doing anything. 


When I try to do a fresh install, both the admin and non-admin versions error out before starting. A tool to completely uninstall Alteryx, including registry files, so that a clean install could be done would be very useful for situations like this. 

7 - Meteor

UPDATE: I was finally able to get everything uninstalled last night. Steps I took are below - I was having trouble with the Predictive Tools, too, so with any luck this process will work for some of you, too. In short: clear Alteryx from the registry, and uninstall any other R engine you have on your system (such as "R for Windows"). Good luck!





1) Reboot, to make sure no background processes are hung up on previous uninstall attempts


2) Open the Windows Registry (search for "regedit" in the Windows Start menu), and delete all Alteryx folders ( was desperate, and willing to go nuclear on the issue).


3) From Control Panel -> Programs and Software, first uninstall "R for Windows" if you have it.


4) You should now be able to uninstall the Alteryx Predictive Tools. I was never able to do so before I uninstalled "R for Windows"... not sure if there was some accidental crossover between the two, or what the reason was.


5) Now, uninstall Alteryx itself (that is, the "Alteryx 11.0 (remove only)", or whatever is left in the programs list). Everything should run as expected.


6) Finally, reinstall the latest version of both Alteryx Designer, and the Predictive Tools


14 - Magnetar
14 - Magnetar
Thanks @Chrispy ! The part that finally did the trick for me was deleting the registry folders. Not just the "Alteryx" folders but the "SRC" too.
I left the registry folders/keys for the license and it worked out perfect - didn't have to re-enter that once the install finally worked.
6 - Meteoroid



I just got off a phone call with Alteryx tech support (Mike F.) and he walked me through this process.  The only keys you need to delete are these -


For Alteryx:





For Predictive (if installed):




Worked like a charm for me.



7 - Meteor

@sehling, thanks for the details.


Unfortunately this did not work for me. When going through the control panel, I still get an error saying I do not have permission to remove the program. This is after I have removed the two folders you indicated from the registry, restarted, and used not only my admin credentials, but had my system administrator use his credentials. 


So, yeah, not cool Alteryx. I just want to remove the old version of your program. Ugh.