Alteryx Designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

Unable to do a clean uninstall needed for upgrade

5 - Atom

I wanted to get on to the latest Alteryx designer and the install pack needed me to uninstall any previously installed package. Now the only thing left is "Alteryx 11.0 x64 (Remove only)" and I am unable to remove it. So the new designer install fails every time. Does anyone know how I can get rid of old Alteryx and do a clean install of Alteryx designer.

7 - Meteor



We ran into this issue while trying to upgrade from Alteryx Server 11.5 to 11.7; the first step of uninstalling the previous version failed, not only once, but three times in different servers, leaving us with a corrupt installation; we tried reinstalling 11.5 but that also failed; this is how we fixed it:


  1. Delete the installation directory, typically C:\Program Files\Alteryx; remember to save anything you may have added under this folder, such as custom macros, before deleting this folder.
  2. Run this Microsoft Fix problems that block programs from being installed or removed troubleshooter; since we install both the Server and R (Predictive Tools), we had to run the troubleshooter twice; however, this is so much easier than hunting down all of those Alteryx and SRC entries in the registry, and safer too. Also, this will run for a while, do not worry, it works.
  3. Install your desired Alteryx version.



5 - Atom

Thanks. This was very helpful!

7 - Meteor

Thanks for sharing this @sehling, worked perfectly. Uninstalled Alteryx, deleted the Alteryx folder and the keys from regedit. Restarted and installed Alteryx and Predictive tool....went smooth

5 - Atom

Go to the following registry 



You will folders with numbers like S - 1 - 5 - 18 


Expand the folders You will find the following folders 





Click on Products - If you find any details to Alteryx - Delete the entire folder.


Then you will be able to install


Please take a backup of registry