community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
Community v19.6

Looks aren't everything... But the latest Community refresh looks darn good!

Learn More

Turn off scientific notation on input files

Atom

Hey,

 

I have a file in which half of data in a column is getting converted into scientific notation. Is there a way to turn this feature off? Or does anyone know of a work around for this? See images below in columns F4 and F6. Note the data in F7 has came in correctly. The workflow screenshot data is taken right after the macro input.

 

Thanks

 

Screen Shot 2016-03-02 at 9.31.53 AM.png

 

Screen Shot 2016-03-02 at 9.38.44 AM.png

Alteryx Certified Partner
Alteryx Certified Partner

I believe a double precision floating point number carries a maximum significant digits threshold which you are probably hitting.

Atom

Would this maximum happen to be 15? 

 

Are there any work around this that you are aware of?

Alteryx
Alteryx

Hi Bland,

 

This is related to how the information is stored in Excel and that Alteryx is pulling in the field as a string (string input is happening because the 2nd row is string). If you want this converted on input, there are a couple of options.

1. Make sure that the format does not allow Scientific Notation in the source file.

2. Remove the first blank row in the source file.

 

If Alteryx sees this notation in a source file field where everything else is a number, this should be converted to an actual number, but if the file is picked up as a string, then it will not be converted. This is expected. Given the look f your workflow, I would advise changing it after input using a Multi-field formula tool. 

Take a look at the following post for ideas:

http://community.alteryx.com/t5/Data-Preparation-Blending/E-notation/m-p/9740/highlight/true#M1619

 

Kane

Labels