Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
SOLVED

Trying to connect to a SOAP web service and finding couldn't connect to server error

Highlighted
5 - Atom


Hello Community;
 
I am trying to connect to a SOAP web service for which I have already tested connection, as well as working with a couple of its available functions\methods. I tested using using Boomerang (Google Chrome Add on and SOAP Client)
 
The service requires an initial Login step, and it sends a SessionID that can then be used for working with the majority of the methods available.
 
Through Boomerang (SOAP Client) I am able to test and connect, retrieve the sessionid and continue working with the rest of the methods\functions available.
 
Within Alteryx, I can't get through the first step of connecting to the server. 
 
My workflow has a simple text input with the URL as well as a Download tool, where I am using the URL from the text input, adding pertinent header information based on the web service requirements and adding the payload for the Login method, just as I will use it in the SOAP client. But it keeps giving me the connection error.
 
Any help\feedback is much appreciated. Attached is the simple workflow so that the setup can be reviewed.

Highlighted
13 - Pulsar
13 - Pulsar

@Juanito70

Have you tried it with "Encode URL" unchecked?

Highlighted
5 - Atom

Hi @patrick_mcauliffe;

 

Yes, and it makes no difference, the same error appears.

 

Upon further review of the issue, it seems that the problem may be configuration related. For some reason I can use SOAP clients like Boomerang, postman, and others and the request(s) and interactions with the web service work with no issues, but Alteryx keeps giving me the 'Couldn't connect to server ' error message. I am working with my Network Team to see what may be different when Alteryx is connecting to the web service.. I have also tested with a machine that is NOT within the same network environment and the Workflow works well, without reporting the connection error and bringing back the expected results.

 

WIll mark the thread as solved.

 

Thanks.

Labels