Alteryx Designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

Transpose not detecting column names

Loading___
6 - Meteoroid

I need your urgent help for this anomaly. This is between the dynamic rename and transpose tool. After using the dynamic rename to change the 1st column name, I use transpose to use the 1st column as the key column, but transpose tool doesn't detect the new column as shown below.

 

Dynamic Rename column headers (outgoing data to Transpose)

Dynamic Rename result/outgoing column headersDynamic Rename result/outgoing column headers

 

Transpose tool, not showing column names from dynamic rename.

Input from Transpose, not detecting the column names from Dynamic RenameInput from Transpose, not detecting the column names from Dynamic Rename

 

Note that my workflow is pretty huge and has over 300 tools due to the large data transformations and formatting. So, how is the transpose tool not detecting the new column names. I've tried running the workflow for it to pick up the new column and it worked for the first time but then it just reverts back to this state. 

5 REPLIES 5
mceleavey
17 - Castor
17 - Castor

HI @Loading___ ,

 

Without seeing your workflow it's impossible to say.

Can you post the workflow (just use random data)?

 

M.



Bulien

apathetichell
17 - Castor

2021-06-17 (1).png

2021-06-17.png

  

Have you hit run yet? This looks like a post-dynamic rename screen where the workflow hasn't been executed yet. Run the workflow and see if it is fixed.

 

In tribute to Sy Sperling, I've included before and after picts.

mceleavey
17 - Castor
17 - Castor

@apathetichell ,

 

that's a good shout...



Bulien

DawnDuong
13 - Pulsar
13 - Pulsar

Hi @Loading___ 

I suggest that you change the sequence of tool slightly. Instead of using a dynamic rename then the Transpose tool (you will need to run 2 times as the 1st time the Transpose tool does not have the names of the column yet... which removes the dynamism of the workflow), you can try something like this:

1) Keep the generic column name  F1, F2, F3 etc... when you read in the file with first row containing data

2) Remove the row you don't want

3) Do the transpose on the generic column names (e.g. F1, F2, FY3...)

4) Then do join to replace the value F1, F2 etc... w the correct column names.

 

This is what I usually do for workflows that need both Transpose and Dynamic Rename. Hope this helps.

Dawn.

BlakeB
Alteryx
Alteryx

Hello, I'm coming across the same issue with Dynamic Rename + Transpose tool not picking up new column names - is this a bug in the Transpose or is it intended to work this way? It only seems to pick up the new field names if I reconfigure the Transpose each time. 

 

I wanted to see if you had any ideas for a workaround for my practice exercise. The way I've built the workflow, it's reliant upon the column names from the Dynamic rename to indicate whether the sales data is 'actuals' or 'budget'. 

 

Please let me know, any help appreciated! 

Labels