community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
SOLVED

Tool: Model Comparison

Asteroid

is there any guild about the tool model comparison?

 

when I try to use this tool I get the following information:

Error: Model Comparison (28): Tool #3: Error in match.fun(FUN) : object 'getXVars' not found

 

Also, in the model comparison configuration page: it asks you to input the positive class in target variable, my target is string  was defined as 1 means bad and 0 means good. What should I input for this question?

 

I hope it could have more documentation about the predictive tools. Thank you so much.

 

1.PNG

Alteryx
Alteryx

Hi @qqqwww, first thank you for downloading and using this tool. My first question for you: are you getting this error also when you run the Model Comparison Sample? If it's the case, what is your current Alteryx version? I've experienced errors with older version Alteryx when running with Model Comparison, but it should work with the latest version of Alteryx.

 

I'm happy to take a look at your workflow if this is not a Alteryx version issue.

 

To answer your second question, I would suggest put "1" in the box without quotes. However, you are probably the best person to answer this question -- what do you consider as your "positive" class? If you application is that you are studying what parts of a machine are "bad", then usually "bad" ("1") should be the positive class. Another example: if you are studying which patients have cancer, then patitents who have cancers are usually considered as "positive"

 

 

Asteroid

Hi@KuoL , thank you for the reply.

 

When I submitted the question, I use 10.1. I don't know if it has the error to run the Sample.

Right now, I have updated to 10.6, when I run the sample, I get the following error information. I have already installed the R predictive packages. But it seems like I need to install the package manually.

Capture.PNG

Alteryx
Alteryx

Hi @qqqwww, we didn't ship the "ROCR" library which Model Comparison Macro depends on with Alteryx 10.6. However, the macro will install "ROCR" package for you if you don't have it installed already. I just removed "ROCR" from my machine, and ran Model Comparison Sample fresh. I didn't get any errors...

 

I think the issue you're experiencing is probably due to restrictions of your R library setup that prevents you to install the package from a thrid party software.

 

However, to install "ROCR" manually is very simple.

 

install.packages("ROCR")

is all you need.

 

 

Let me know if you still can't run the Model Comparison Sample.

Asteroid

I tried to install the package and re-run the workflow, same error.

Capture.PNG

Then I tried to uninstall the package, same error too.

222.PNG

Alteryx
Alteryx

Can you try:

install.packages("ROCR", repos="http://cran.us.r-project.org")

And verify the package is indeed installed by:

help(package = "ROCR")

You should see something like this:

help(package = "ROCR")rocr.png

 

 

 

If the repository mirror: "http://cran.us.r-project.org" doesn't work for you, go to: https://cran.r-project.org/mirrors.html and pick one that is in your country.

Asteroid

It is success installed. Then I run the sample workflow, same error....

 

 

1.PNG

2.PNG

 

Meteor

Hi,

 

I had the same problem, this was my solution :

 

Step 1 : Go to R to download the ROCR package :

1.PNG

 

Step 2 : go to the directory C:\Users\my_name\AppData\Local\Temp\RtmpOoEUKw\downloaded_packages

Step 3 : unzip the file ROCR_1.0.7.zip

Step 4 : copy the folder generated in step 3

Step 5: paste the folder here : C:\Program Files\Alteryx\R-3.2.3\library

Step 6 : run Alteryx.

 

Hope this will help you.

 

Best regards,

Gilles

Highlighted
Asteroid

Hi @gmerce, thank you so much. Good solution.

 

I forgot to update this question. 

I contact artery clients server , they help me install and uninstall the packages by lots of way and fix it .

Labels