ALTERYX INSPIRE | Join us this May for for a multi-day virtual analytics + data science experience like no other! Register Now

Alteryx Designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
SOLVED

Tool Install Error - "Could not build wheels for cryptography which use PEP 517..."

jsandona
6 - Meteoroid

Hello, I'm trying to install the Microsoft PowerBI Output Tool in Alteryx (I've tried on versions 2020.2 and 2020.3) and am getting the error message below:

 

An error occurred during installation.

ERROR: Could not build wheels for cryptography which use PEP 517 and cannot be installed directly

 

Has anyone run into this before and know a fix to try? The articles I've been seeing online are focused on python and don't mention Alteryx. Thank you!

 

jsandona_0-1612214299126.png

 

echuong1
Alteryx
Alteryx

The backend of the PowerBI output is actually Python, which is why you're primarily seeing help articles related to that!

 

With regard to this error, I've seen it once before. Another user on Community posted these instructions, which resolved it. You can also reach out to Support@alteryx.com to get help with this.

https://community.alteryx.com/t5/Alteryx-Designer-Discussions/Email-Tool-Broken-on-2020-3-upgrade/td... 

 

echuong1_0-1612216336459.png

 

jsandona
6 - Meteoroid

This worked! Thank you @echuong1

Labels