cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Too many fields in record#1

SOLVED
Asteroid

Thanks! I've been using a similar approach with a pipe delimited file, but then the layout changes sometimes adding or removing a field... thanks to some poor manual intervention each time they output the data to me so the addition of counting the pipes first will save me a lot of time in the future. I don't know why I didn't think of doing that!

Asteroid

This approach works for me but it just seems bizarre that I can import the exact same file into MS Access or SQL and I don't have this issue. The file is an extract coming from a mainframe I believe, and it is in pipe delimited format has about 70 columns. I've been using the workaround for quite a while now kind of thinking eventually Alteryx will get on board with handling pipe delimited files more efficiently and easily. So after ever update I try the file again and it still never works. I also had issues outputting data back to that same group but I believe with v11 and unchecking the BOM that will take care of that problem I'm testing a file now so thanks for adding that feature!

Asteroid

I run into the same issue. But following your method not working!!

@MarqueeCrew

Asteroid

Can you post your flow with some sample data I'd be happy to take a look as I went through this issue a number of times before I got it sorted out with solution proposed above.

Asteroid

Attached please find sample data. I have 4.4 milion records in the file.

Asteroid

Here's a workflow for your sample data, let me know if you still get an error, it may be in the data itself there's someone storing info with a Pipe within a field, but Alteryx should give you the row that it errors out on. If this solves it for you let me know!

 

Thanks,
Neal

Highlighted
Atom

This solution fixed the issue I was having when importing one of my .csv files. 

Thanks so much.