Do you use Alteryx in a language other than English? If so, we want to hear from you! Please help us improve the international experience of our products by participating in this 5 minute survey.

We are updating the requirements for Community registration. As of 7/21/21 all users will be required to register a phone number with their My Alteryx accounts. If you have already registered, you will be prompted on your next login to add your phone number.

Alteryx Designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

Time Series TS Model Factory errors

GiorgosK
5 - Atom

Hi all, 

 

I am using ARIMA TS Model Factory and I have got this error  "TS Model Factory (51): Tool #64: Error: object 'past_coeff_vec' not found"


Also in the same data I am using ETS TS Model Factory and I am getting the following  "TS Model Factory (55): Tool #64: Error in ncol(previous.output.table)" 

 

Any ideas what this error is?

 

Thanks

7 REPLIES 7
JessicaS
Alteryx
Alteryx

Hi @GiorgosK,

 

Can you provide your workflow so we can get a sense for the data and setup?

 

I haven't seen this particular error before, but in general, it's a good idea to take a look at the data to check for any null values or irregularities.  If you are able to provide a sample of the data and workflow we can get a better idea of the issue.

 

Thanks,

Jess Silveri
Manager, Technical Account Management | Alteryx
User514
6 - Meteoroid

Hello I'm having the exact same issue would you be able to provide an answer?

 

I'm using ARIMA and ETS on a quartely interval.

 

I've added my data to help.

 

User514
6 - Meteoroid

Uploaded the wrong data.

 

Reuploading to correct

salkhafaji
5 - Atom

If you are trying to forecast the data quarterly, you have to make sure your IDs have consistent periodic measurements.  I.e.  ID 34 has 2 data points for Q-1 2019 and ID 37 doesn't seem to have Q1 2018.

Vignesh_07
5 - Atom

Hello,

 

Were you able to resolve the above two errors you mentioned? I'm facing the same problem and would be really helpful if someone could help resolve this.

 

Thank you

Vignesh_07
5 - Atom

Hi @JessicaS 

Were you able to resolve this issue. I'm getting the same errors when i use the TS Factory macros

Attached the files for your reference

 

Please advise

 

Thank you

User514
6 - Meteoroid

I solved it by making sure I had at least 6 observations per grouping method, and ensuring my data was sorted by date before it went into the models. Hope it works for you too

Labels