Early bird tickets for Inspire 2023 are now available! Discounted pricing closes on January 31st. Save your spot!

Alteryx Designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer and Intelligence Suite.
SOLVED

The Designer x64 reported: InboundNamedPipe::ReadFile: Not enough bytes read. The pipe has been ended.

Hi -

Has anyone encountered this error? We're running Alteryx Designer 9.5 on Windows 7 Desktop. This error is thrown right when the module results the output to an Oracle table .

Error: Designer x64: The Designer x64 reported: InboundNamedPipe::ReadFile:  Not enough bytes read. The pipe has been ended.

Thanks for any help!

Arul

50 REPLIES 50
sakenk
6 - Meteoroid
Hi Arulvelan, 

Sounds like an out of memory error. How much data are you writing out? Are they all strings/integers, etc?
ben_stroud
7 - Meteor
I also have encountered this error. See attached screenshots. Since the error mentioned "Designer" I tried also running the workflow from the command line using AlteryxEngineCmd.exe. In that case the job simply crashes with no useful error message. It did seem to crash at the same place according to log output. I really need to resolve this and the error doesn't provide any useful clues. Alteryx, how can I debug this? I have confirmed plenty of physical memory and disk space.


ben_stroud
7 - Meteor
Following up on my earlier post. I was able to track this down to a currupt yxdb being read. I had copied the yxdb files from another networked server. The file sizes were the same but apparently the files were not exactly the same. Recopying the yxdb file fixed this InboundNamedPipe error upon rerun.
Kuehner
7 - Meteor

I have the same issue here.

But even when using a local file, which is admittedly quiete big (120 Mio obs).

I can open the input file, page up and page down works fine, but once I grab the handle to jumb to a different section of the table Alteryx crashes.

Is that due to a corrupt table or being a temporary memory problem (I have 8 GB working memory ad hand).??

 

Cheers Tom

TaraM
Alteryx
Alteryx

This is a common error that is typically thrown for unknown reasons.  Sometimes it is due to a corrupt file as mentioned above, but normally it occurs because of an unaccounted for reason.  Other users have reported changing a Union tool from Manual Configuration to Auto has resolved the issue as well. When you get this error, it is best to reach out to your Client Services Rep who will work with you directly to try to reproduce and fix your issue, or so it can be escalated through the proper channels. 

 

 

Tara McCoy
BWitonsky
5 - Atom

So I ran a workflow a few times with no issue.  Then had this issue from Union.  Spent an hour recreating files, rerunning etc.  Finally deleted the Union tool and rebuilt and the workflow finally ran. 

jim_kalogerakos
5 - Atom

Came across this error when outputing a file to 1) YXDB and 2) SAS format simultaneously (2 separate outputs). The SAS file did not get generated, so likely an issue with writing the yxdb. I went into the output tool and ensured the output file name included the .yxdb extension and it seemed to resolve.  

mohsin
7 - Meteor

Thanks for the pointer. In the Union step, I changed from Manual Config to Auto Config by name and this error disappeared. Wiered. 

JohnJPS
15 - Aurora

I had a similar issue today and it was a cache object that had gone bad for whatever reason. Restarting Alteryx cleared the cache and took care of it.

Labels