Alteryx Designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

The Designer x64 reported: InboundNamedPipe GetOverlappedResult: The pipe has been ended.

ftorres
7 - Meteor

Hello everyone,

 

I've moved my Alteryx Designer running on Windows 10 in a VMware Fusion virtual Machine from a MacBook Pro to an iMac Pro (just by copying the Windows VM) and suddenly I'm getting only in some of my workflows the following error when trying to write *.hyper files (*.tde outputs seems to work OK):

 

The Designer x64 reported: InboundNamedPipe GetOverlappedResult: The pipe has been ended.

 

It's really weird because the workflows where running without problems before. BTW I'm the Admin of my Machine, I'm using the following Alteryx's version (because I'm using the Scheduler too, but not for the workflows with the errors):

 

Alteryx Admin Designer

Version 2018.4.5.55178

Running Non-Elevated

 

and my workflows have *xydb inputs that are in a network disk location where I can read/write and my outputs are also in a network disk location where I can read/write.

 

This error is very similar than the ones to be found in another threads but not quite the same so unfortunately I haven't been able to find any help to tackle it. Can I maybe turn on something to catch more details for the error handling?

 

I really appreciate any Feedback, since the error is affecting production workflows.

 

Thanks in advance!

Felipe

37 REPLIES 37
Maruchan
5 - Atom

I'm getting the same error now for a workflow I was able to run before. Similarly to other users here I didn't change anything in the workflow except for providing new input files and updating the output file names.

 

  • I tried all the possible solutions provided here and tried performing a complete uninstall following the steps in this post but nothing has worked so far: https://community.alteryx.com/t5/Alteryx-Designer-Knowledge-Base/Complete-Uninstall-of-Alteryx-Desig...
  • The workflow is quite big and takes over 30min to run so it's difficult to pinpoint what is causing the issue.
  • The workflow is posted to our company's gallery and other people are able to download and run it on their machines without any issues.
  • I've been running the workflow regularly for a few months and the error started appearing last month. I use Designer very often and haven't encountered the issue on any other workflows.

Anny additional advice regarding this error would be helpful!

DavidBaker84
6 - Meteoroid

Hi,

 

I have had the same issue a few times.  In the past I have been able to resolve this by either, clearing cache, temp files, restarting the app, or copy the workflow and creating it in a new tab.

 

However that is not working for me now.  My workflow previously worked when I was exporting using a standard output tool to excel, I have multiple tabs, and I generate a new file dynamically each time.  I have tried to change this to a Render Output, still required the file to have been created dynamically, so I cant pre-set this output, and have multiple tabs on the output.  As soon as I add my 1st Render tool I get this error and cant shift it.  Screenshots below of my Render Config, and the Table I am trying to output.

DavidBaker84_0-1603986369228.png

DavidBaker84_1-1603986391382.png

 

 

jf_aero67
5 - Atom

This worked for me. Thanks!

Sonali_Gaidhane
5 - Atom

Hi,

 

I was also facing same issue.

 

I have changed my column from V_String to  Double in Select tool.

 

Actually i was importing data from Excel file into Database table. In database table , i had data type number and my excel had V_string.

 

Please check the datatype and accordingly give the datatype.

 

 

Ampherius
5 - Atom

I had the same issue with a workflow consists of a bunch of macros.

Once an extra macro was plugged in, the inputs I had worked, started to have issue with this warning. We fixed it by converted data type from numeric value to a string, because the calculation I had was a text formula on a numeric value field. With your case, it could be a reversed conversion. The issue is on the data field type usually. 

Sajana_J
5 - Atom

The reason seems to be the mismatch between the data type and the size guys. I faced the same issue and got it sorted like this.

 

Scenario: Scraping a website and uploading the scraped data to a table in a oracle database.

 

I had defined the destination table to be VARCHAR(50) for certain fields in the oracle database.

 

Scraped data from the website in Alteryx, the same data fields were defined as V_WString(1567645) which was a large bucket than the destination. 

I simply change the V_WString(1567645) to V_String(50) to match the source and the destination. It worked for me.

 

Thank You.

denvic29
7 - Meteor

denvic29_0-1627915317550.png

 

I have two workflows both saved on OneDrive, all input files on OneDrive, and trying to export to Excel on OneDrive. Each workflow is processing a good volume of data and takes about 10 minutes each to run. I have had this error in the past and went and checked issues like data type/size, etc., and had gotten both working. I had both able to run as of two days ago. Today, all I did was "save as" each workflow as a new date and try to run them and I am back to getting this error on each of them. I am starting to be at a loss for why this keeps recurring. Is there something else I should check on my machine? I can't pinpoint when the error comes up easily.

 

elocke
6 - Meteoroid

I had this same issue for a LONG time on a workflow that had been working for years, and randomly started failing back in February. The fix for me was adding a "Block Until Done" tool in front of a "Download" tool that was running in parallel with other parts of my workflow. This error may occur (with my limited knowledge and observation) when Alteryx tries to do too much at once in parallel, and adding a "Block Until Done" at the correct point in your workflow could keep it from biting off more than it can chew.

 

Hope this helps!

Labels