Alteryx Designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

The Designer x64 reported: InboundNamedPipe GetOverlappedResult: The pipe has been ended.

ftorres
7 - Meteor

Hello everyone,

 

I've moved my Alteryx Designer running on Windows 10 in a VMware Fusion virtual Machine from a MacBook Pro to an iMac Pro (just by copying the Windows VM) and suddenly I'm getting only in some of my workflows the following error when trying to write *.hyper files (*.tde outputs seems to work OK):

 

The Designer x64 reported: InboundNamedPipe GetOverlappedResult: The pipe has been ended.

 

It's really weird because the workflows where running without problems before. BTW I'm the Admin of my Machine, I'm using the following Alteryx's version (because I'm using the Scheduler too, but not for the workflows with the errors):

 

Alteryx Admin Designer

Version 2018.4.5.55178

Running Non-Elevated

 

and my workflows have *xydb inputs that are in a network disk location where I can read/write and my outputs are also in a network disk location where I can read/write.

 

This error is very similar than the ones to be found in another threads but not quite the same so unfortunately I haven't been able to find any help to tackle it. Can I maybe turn on something to catch more details for the error handling?

 

I really appreciate any Feedback, since the error is affecting production workflows.

 

Thanks in advance!

Felipe

37 REPLIES 37
bpschoon81
6 - Meteoroid

I'm getting the same error on 2019.1. No long characters or fields in my data.

 

 

MichaelAd
Alteryx
Alteryx

Hi @ftorres,

 

Please feel free to reach out to support@alteryx.com as this issue most likely requires some deep diving.

 

Regards,

Michael Adler

Customer Support Engineer
Alteryx 

Michael Adler
Sr. Customer Support Engineer -- Knowledge Management Coach
Alteryx, Inc.

jensroy
9 - Comet

Hello!

 

I just had this issue myself. We were reading data from Qlik in QVX format. This file has metadata saved for each column.

The issue was that the Qlik file said "Column X" has data type "DOUBLE". But on 5 out of 1 000 000 records, there was a text string insdie the column.

 

Browsing the file with the browse tool crashed Alteryx and closed it immidiatly. So Alteryx seems to be so stressed out about this that it dies of an immidat heart attack, pannicing as it thinks "I know every number in the whole world, why can't I figure out which number 'ABCD' is?".

 

So I added a select tool right after the source file, then changed field type to VW_String. This was Alteryx didn't crash and i found the rows in question. Then we had backend fix the issue before the export. It could have been solved by chaning type back to Double again, but then I would get null values. 

charlep_dup_424
6 - Meteoroid

I had this issue when writing out spatial data to a .hyper file.

 

The issue manifested when I had shapes with 0 area (in Australia, the census allocated people who are working offshore to a notional geospatial area with 0 sqm).

 

When I removed the shapes with 0 area (spatial info + filter) it wrote out fine.

Robert_Blackey
7 - Meteor

This error seems to pop it's head up in several different places.

 

We had it appear when reading data from Snowflake. A straight select statement with just the field names worked, but adding a WHERE clause caused this error.

 

We haven't worked out all the nuances yet, but we found that fully qualifying all the field names allowed the where clauses to succeed.

 

CamodCPA
8 - Asteroid

I ran into this error as well while batch converting xlsx to pdf with a batch macro.

sk1909
8 - Asteroid

I am getting this error with a process I've been running for over 2 years now.  Nothing has changed in my workflow. I just started getting the error message a couple of weeks ago. I'm actually going to sit and watch it today and see where the error hits.  It is a very long, detailed workflow.

Robert_Blackey
7 - Meteor

Hi @MichaelAd 

 

Do you have any updates on this error? It seems to come up in many different situations. Is it actively being addressed?

 

Thanks,
Bob

 

 

sk1909
8 - Asteroid

I found a solution someone else posted and tried that and it worked.  I went to the tool that was having the issue and changed the location of the file it was referring to and saved the workflow.  It worked.  No more issues.  Finicky, I guess.

TrevorS
Moderator
Moderator

Hello @sk1909

Can you please include a link to the post you used which helped you with resolving this issue so that other users may try as well?


Thanks!

TrevorS

Community Moderator
Labels