Alteryx Designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
Don't forget to submit your entry for the Excellence Awards by October 30! | Need more information about the program? Check out the blog here
SOLVED

Text tool link changes special characters in link

Highlighted
9 - Comet

I was liking the Text tool a lot until I got stumped.

I need to put in a link to https:\\tableau\#\site\...etc

Text tool keeps changing the # to %25 and the link doesn't work.

I tried ## and got %25%25

Is there an escape character I can put before the # so it will not change?

Highlighted
Alteryx
Alteryx

@hroderick-thr I think you are talking about the report text tool. I would put in a hyperlink, give it the proper text to display and the url associated with it. Just tested it, it works as expected. 

 

for example:

<Link Test|https://tableau.com/#/views/App/Dashboard1?:iid=14>

 Let me know if you need help setting it up. 

Digan
Alteryx
Highlighted
9 - Comet

I believe it would work if I coded it like you advised. And I REALLY appreciate the fast answer.

But I left out part of the story.

The link I'm trying to insert needs to be dynamic.

It ends with a filter like https:\\tableay\#\…?dataowner=hroderick 

and the hroderick changes to other people.

 

I tried the forward stash / . 

EUREAKA it worked. \/#\  became \#\

I got an email with the \#\ in the link

So for Alteryx it is solved!

 

My joy was short-lived when outlook changes the # to %23

That's a plea for a different board

 

Thanks again

 

 

 

Highlighted
9 - Comet

Unfortunately I clicked the solved button prematurely.

Hovering over the link looked right, but viewing code or actually using the link did not.

 

I did solve my situation but not with special characters.

I got a different coding for the link by using the share feature in tableau.

It used a t instead of a #, avoiding the problem.

Here is the Alteryx formula I that produced a working link

 

'https://tableau/t/THR-Tableau/views/TableauDataOwnerReview/DataOwnerReview?Dataowner Friendly Name=' + [Name]

 

Labels