Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

Teradata Connection Error After Change Password


Hi, Currently I am having a Teradata Connection Issue. Very very wield one and it seems to be product bug to me.


I changed my system password and I can still log into my Teradata Studio but not from Alteryx with my original connection name, let's say it's TDPRD. Error message:


Error: Connect In-DB (6): Error SQLDriverConnect: [Teradata][ODBC Teradata Driver][Teradata Database] The UserId, Password or Account is invalid. [Teradata][ODBC Teradata Driver] Not enough information to log on


I actually can see those table names and view names in query builder but it still shows error when I run the workflow.


So I build another connection with a different connection name, let's say it's TDPRD2 and it would work. I tried to delete my old connection TDPRD and rebuild it with same name TDPRD again and it would still shows up error.  

No matter how I configure the ODBC driver , or delete it and rebuild a new one, it won't work but the new  connection TDPRD2 would work just fine.


And no matter whether I type in my passoword in ODBC connection, it would shows error. But again, the new connection TDPRD2 would still be fine.



It looks like a cache issue to me. I really need my TDPRD connection as whe whole team is using this connection to run workflow.


Please Help Me Out! Thank you so much! Already stuck on this issue for two days...


Alteryx Certified Partner
Alteryx Certified Partner

Random thing to try.

Go to 'Options' > 'Advanced' > 'Manage Data Connections'.


If your connection appears here I would delete it then add it again.



Hi thanks for your reply!


I do delete it and rebuild a new one. But if the new one is under another name it would be fine, if it still be the original name it would still show me the same error. Any thought on this?


@JasonH123 The password seems to be cached somewhere, probably in the registry key. Go to HKLM\SOFTWARE\ODBC\ODBC.INI\<CONNECTION NAME> and check the password key. You can change it there manually as well.


I am having the exact same problem.  I have tried Options-Advanced Options-Manage Data Connections with no luck. Was a definitive solution found? I have no idea where to find HKLM\SOFTWARE\ODBC\ODBC.INI\<CONNECTION NAME> 



Hi @galex,


@DiganP is referring to a registry path within regedit.exe. One thing to note though - The path is dependent on the connection type (User vs. System). A User connection will reside in HKEY_CURRENT_USER\Software\ODBC\ODBC.INI, whereas a System connection will reside in HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBC.INI.


@galex's internal Teradata Help was able to resolve the issue with the following instructions...


  1. Open ODBC Admin and configure DSN having issue.
  2. Do NOT save password in the DSN config.
  3. Go to Options>>Advanced - Increase timeout setting from 20 to 3000, for example.
  4. Save the config.

One more thing that the he mentioned was setting the DataSource DNS Entries to 1, but that is likely specific to their environment. Worth mentioning though:


I see the Computer\HKEY_CURRENT_USER\Software\ODBC\ODBC.INI\Teradata_Production but what do I do once I am there. I am having the same problem as this thread. I was able to connect to Teradata last week but on Friday and today, it says invalid username and password. I have updated my Teradata driver but still cant connect.