community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
Upgrade Alteryx Designer in 10 Steps

Debating whether or not to upgrade to the latest version of Alteryx Designer?

LEARN MORE

TableauServer.Login: Tool #4: Tableau Server API Request (Error Code 401001)

Alteryx Partner

I'm having the same issue myself and a colleague is having the same issue at another company.

Meteoroid

I'm receiving the same set of errors myself when uploading to the Tableau server. The weird thing is that when a coworker puts in his credentials, the work flow works flawlessly from my computer on the same workflow. It's only when I add mine that I receive the error. This error persist across every workflow that I have needing to upload to the server. It is not work flow specific.

 

Before you ask, YES my credentials are correct. I've logged in and out of the Tableau server many times to ensure that I'm using the correct username and password. Does anyone have a fix that isn't "keep using your coworkers credentials"?

Alteryx Partner

Have you ensured that you don't have more than one special character in your password?

Meteoroid

Unless numbers count as special characters, then there are no more than 1 special characters in my password.

Meteoroid

from another post....

https://community.alteryx.com/t5/Alteryx-Designer-Discussions/All-my-workflows-with-Publish-to-Table...

 

Its not necessarily more than one special character but it could be the type of special character or if your password starts with a special character.  I have been having this same issue and fixed it but changing my password to not start with a special character or contain any common escape characters.  

 

Best of luck.

Thanks for the tip! Changing my password to avoid too many special characters also worked for me. I can't imagine I would have found this solution otherwise!

Labels