Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
Alteryx is here to help you solve your biggest data challenges. Read about the new Virtual Solution Center here.

Table Tool Data Type (String/Integer)

Highlighted
8 - Asteroid

Hi, I have Postal Code column and used select tool with datatype to V_WString it converted the data to string but i get the warning "Number stored as text" when i open in excel. The default type for all column once the render tools outputs the excel file become "Number" automatically even though my data is V_WString. Any solution to remove that?

 

I have attached the warning message and data type showing "Number" i get in excel here. 

 

Highlighted
11 - Bolide
11 - Bolide

Hi @dineshp,

 

I had a look at your scenario and tried to replicate - see my attached workflow.

 

First i tried to see how number values with enforced V_WString type look when you save into csv format, but they come out simply as numbers (this is expected, as csv is format-less).

 

My recommendation is to flow this field/column as a numerical type Int32 or higher due to range (Int16 does not cover your range as per your examples) and take care about formatting in Excel.

 

I noticed you can apply a Speciaf format as postcode (just provide your location) or you can enforce formatting using wildcards as below.

 

img1.JPGimg2.JPG

 

Thanks,

Rafal

 

Excuse me, do you speak Alteryx?

8 - Asteroid

Hi @rafalolbert 

 

I am not writing into a CSV. I am writing it to Excel workbook .XLSX format. I am appending images and formatting using Table and Layout. So, i am using the 'Render' tool to put the excel file. This is going to be to be automated so i cannot every time open and change the excel data types.

 

This Postal Code is an example. I have ID's, Phone number etc which are following through as String but in the output excel file they are converted to "Number" and represented as 123,456,789 (with comma) which i don't want.

 

The Table tool or Render tools as far as i am understanding is outputting all columns into a 'Number' format irrespective what data type flows through it. Is there any way to change that ?

 

I have attached a sample workflow.

Labels