Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

Standard Macro - Will Not Show Field Map / Allows For No Configuration / Bombs At Run Time

Highlighted
11 - Bolide

Edit:  Figured it out.  Cannot find a way to nuke.  Do not answer.  Thanks. 

 

Hello Gurus - 

 

I have a standard macro.  Works great when I run it on it's own with a file input turned Macro Input.  I have the 'Show Field Map' checked on the Macro Input.  Great.  I bring it into another workflow, and I get no opportunity to select fields / perform configuration. 

 

Questions panel if I select the macro reads: "This Standard Macro requires no configuration". 

 

When I run my workflow, it bombs at the macro, with 'Internal error processing macro:  missing field map for "[Input Name]".  No kidding it isn't showing me a map to configure!  

 

I have tried nuking and recreating the macro input.  If I change to a batch macro, I get a field map, but I do not need to do grouping on this thing!  I have tried restarting alteryx, checking and unchecking the 'show field map' checkbox with no love.  What am I missing here?  

 

Can someone help? 

Thanks.

brian

 

Highlighted
Alteryx
Alteryx

Hi @brian_scott ,

 

Would you mind sharing for the community what resolved the issue?

 

Thanks in advance!

 

Amelia

Highlighted
7 - Meteor

Experiencing same issue.  Funnily enough had same macro in workflow twice and it worked fine first then fell apart the next time... my guess it has something to do with order of how it checks for available meta data

Labels