community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
Community v19.6

Looks aren't everything... But the latest Community refresh looks darn good!

Learn More
SOLVED

Slow working in Alteryx Designer when connections to databases are bad

Meteoroid

Hi, sometimes I need to work outside the office on trains or other rural areas where the internet connection is slow (or no internet at all). Working in Alteryx Designer is then very frustrating and time-consuming. It seems like every time I enter a tool, add a new tool or do any operations at all in the workflow; Alteryx is checking the metadata of all the connections and won't let me do anything before all database connections are checked. 

 

I'm using ODBC-connections to SQL-server both with Input Data-tool and Connect In-DB-tool. I have Alteryx Designer 2019.1.

 

Is it possible to turn off updates of metadata to my database-connections like I can turn off automatic calculations in Excel? 

May I alternatively work in Offline-modus where Alteryx is using the last know metadata information? 

 

PS: That is goes slower to Run a workflow with bad internet connection is expected, and not what frustrates me. 

Alteryx Certified Partner
Alteryx Certified Partner
Disabled containers could be your new best friend. Keep some sample data in one container and a real connection in another. Union the data together and disable as appropriate.

Cheers,

Mark
Alteryx ACE & Top Community Contributor

Chaos reigns within. Repent, reflect and reboot. Order shall return.
Alteryx
Alteryx

Yeah, you can turn this off. It's known as auto configure.

 

You can get the options in designer by: Options > User Settings > Edit User Settings > Advanced > Disable Auto Configure

 

It's worth noting that it can be a bit painful not having the metadata refreshing. F5 will force a refresh.

 

I'd recommend utilising this along with the cache and run workflow option.

Meteor

Hi,

 

I have run into this issue before as well and usually solve it 1 of 3 ways depending on whats best from you.

 

1. If possible for your business problem, consider loading only 100 or so rows instead of full population. This will enable you in poor connections to download small amounts of data that even on poor networks shouldn't take too long.

 

2. Download the data trying to be pulled from DB into a .yxdb or other local file you can use during bad connections, then swap out when in better network

 

3. Cache tool should allow you to run your workflow before you leave office or wherever you are heading and store it in your workflow so it doesn't have to go back out to server every time you press run.

 

Hope 1 of these solutions helps you out, let me know if you have any questions.

Meteoroid

Thank you all for the replies. It seems like the solution from JoeS was the one that fits me best :-)

 

Where do I enable "the cache and run workflow option"?

Highlighted
Meteor
You can enable the “Run and Cache” by right clicking the input tool and selecting the option from menu.
Labels