community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
Upgrade Alteryx Designer in 10 Steps

Debating whether or not to upgrade to the latest version of Alteryx Designer?

LEARN MORE

SharePoint List Input Error

Highlighted
Atom

I am trying to connect to a SharePoint 2016 list and when I select the list from the drop down and try to run the workflow I receive the following error: Error: SharePoint List Input (1): Error encountered: The property or field has not been initialized. It has not been requested or the request has not been executed. It may need to be explicitly requested.

 

Any idea what this means?

Alteryx
Alteryx

Hi User4524,

 

Try formatting the username along with the domain i.e. <domain>\<username>. Also, you may need to select Save Connection to save the connection URL and credentials before you run the workflow.

 

Here are some instructions and notes that may be helpful.

 

To set up the connection.

  1. Enter the full URL to your SharePoint site. If you have already connected to SharePoint, previous URLs will be listed in the drop down. The URL should point at the list-level page.
  2. Enter your Username and Password.
  3. Save Connection History - This option saves Username and Password information so when you select the URL from the drop down the Login information will auto populate.
  4. List: Type the list you want to read or click the '…' to see existing lists to connect to
  5. Record Limit: Type in desired record limit. If nothing is entered, all records will be read.

 

The Save Connection History option only saves the connection history (URL, Username, Password). This option does not save the Configuration Settings (List name, record limit).

 

The SharePoint List Input Tool cannot download a file. However, you can use a combination of the SharePoint List Input to read the list and the Download tool to bring a file down.

 

Some users have run into issues if the file names on SharePoint have spaces in them. This can cause a 400: Bad Request error to be thrown by the download tool. You can get around this by removing the spaces in the file names on SharePoint.

 

Please reply to let us if further assistance is needed. 

 

Eric West
Customer Support Engineer
Alteryx, Inc.

Atom

I am facing the same problems, but i am inputting an Sharepoint list event instead. The steps you listed is just normal configuration which we have followed but still doesn't solve the problem. 

But when i changed the view from "All Events" to another customized view, it worked. Any idea why? 

Alteryx
Alteryx

Hi @clee06

 

Is the All Events view a task list? There is a currently limitation with the Sharepoint tools that prevents writing to Task Lists. I think this may be due to the Task lists having pre-defined content types and columns, whereas Custom Lists are configured to match the data being added.

 

Based on other Community post, the limitation may include reading Task lists as well: Sharepoint Task List.

Atom

@clee06, I had a similar experience where I would get this error when a column in the selected view has a type of Hyperlink. If I switched to a view that didn't include one of these column types it worked just fine. In this scenario I'm connecting to a 2013 SP List. Unfortunately, I came here seeking a solution so I don't have any suggestions to fix this issue.

 

Is this a known issue with the tool or is there something I'm doing wrong?

Labels