Now that it's live, don't forget to accept your certification badge on Credly today! Learn more here.
We are currently experiencing an issue with Email verification at this time and working towards a solution. Should you encounter this issue, please click on the "Send Verification Button" a second time and the request should go through. If the issue still persists for you, please email support@alteryx.com for assistance.

Alteryx Designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

Settings Not Saving 2020.4

EW
10 - Fireball

My settings changes aren't getting saved when I re-open Alteryx.  This was happening on the prior version, and I recently updated to 2020.4, non-admin and it's still happening.  Specifically, I want to save default tool palette options, pin the results panel to the bottom of the screen, and turn off the super annoying "ready to start solving" pop up.  

 

I've tried everything I've seen in other solutions, but a lot of it seems older and nothing has worked so far for me.  Specifically, I've tried:

  • Save Layout & Settings on Exit is checked
  • Save Layout & settings now
  • Show Start Here at Startup is unchecked
  • Reviewed the UserSettings and DefaultPalette XML files, but the changes I'd need to make aren't obvious to me and I'm not finding what edits to make online specifically.

I'd really love to fix this, any ideas?  

7 REPLIES 7
JonBlent
6 - Meteoroid

I have the exact same issue. Would love to know what the fix is.

 

J

Qiu
17 - Castor

@EW @JonBlent 
Check the file inside this folder if you are in Win10.

C:\Users\%USERNAME%\AppData\Roaming\Alteryx\Engine\

In there, there is a "UserSettings.xml" file which is the user settings.

Normallly you should have write access for it, but in your case, maybe you are not.

 

EW
10 - Fireball

Thanks Qiu!  To reiterate what I said in my original post, I'm aware of this file but I was unable to find any information on what specific text to add/edit to make the changes I want.  

JonBlent
6 - Meteoroid

OK,

 

So, I changed the toolbar to remove certain palettes. The file called DefaultPalette found at C:\Users\blentj\AppData\Roaming\Alteryx\Engine\2020.4 had an updated timestamp and looks like this

 

JonBlent_0-1613030101058.png

I then closed alteryx

 

When i reopen Alteryx my toolbar looks like this

 

JonBlent_1-1613030200531.png

 

So, the file update part is working but Alteryx is not using it.

 

EW
10 - Fireball

Mine is similar to @JonBlent - DefaultPalette shows spatial as visible but Spatial isn't showing up by default when I open Alteryx.

 

EW_0-1613143718075.png

 

SeanAdams
17 - Castor
17 - Castor

Hey all,

Not sure if this has been resolved yet - but it may be worth logging a ticket on support@alteryx.com - that way at least you can get an issue ID for this (since it seems to be widespread)?

Raphael_Ar
7 - Meteor

Hello, I believe the solution from Sophia will help you. Worked for me.

Solved: Tour and Default Settings on Start Up - Page 2 - Alteryx Community

Labels