Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

Scheduled Workflow Cannot Access In-DB Connection File


I figured it out - didn't know how to delete my post.

All of the following had to be in place:

> Connection file has to have the .indbc connection and in the same directory as the workflow

> Workflow dependencies - must be ALL UNC

> Workflow must be run as a different worker - entered my user credentials (under Options, Advanced, System Settings, Worker...)

> Schedule workflow using copy in Scheduler DB




I have the desktop scheduler (no server).


I can’t seem to make the scheduler work for me even though manually running the workflow works.  The scheduler runs but I get an error:

Start: Designer x64: Started running at 2016-06-20 10:48:16

Error: Tool #4: Unable to access file connection "s:\data science\ro\cdwp file.indbc"

End: Designer x64: Finished running in 0.1 seconds


I’ve tried all kinds of configurations –

  • Run workflow from scheduler and from original location.
  • Created a connection file in the same directory as the workflow. (BTW, am using indb connection – typically, using a user version but when I switch to file the tool says it saves it as an .indbc file; however, you have to specify the extension .indbc for it to work).
  • Edited workflow dependencies – tried relative, absolute
  • Run worker as a different user and entered my windows AD credentials; run using default


Anything you can do to help, I would appreciate it.






Hey @mscuaycong,


You should give yourself credit for the solution by marking this as solved! :-)


Have a good weekend Melissa