Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

Salesforce Output - Dreaded INVALID_FIELD error


I experienced this error when attempting to output the results of my Alteryx data blend workflow to Salesforce using the 'Salesforce Output' connector tool for an Update operation:


Salesforce Output (27)	Record-level error from Salesforce API: 
"INVALID_FIELD:Number of fields in header is different from the row. header = 15 row = 10:--"

I checked 'header 15' and it is the 'Id' field/header in my output that maps back to the existing Salesforce record so an update can successfully be performed-- I even have a 'Unique' tool set to catch any duplicate Salesforce Record Ids, and the issue is persisting.


Of the 67 records, 38 were successfully updated and 29 were not- any idea how this error can help me triangulate what the issue is?

Do you see anything suspicious at data level. Please compare cell level data for sample records which got failed those which got inserted.



Rohit Bajaj


Hey Rohit, thanks for the reply and excellent suggestion. I did actually output the entire results batch to compare all the records, but I couldn't find any pattern for the records that failed to insert.


I was able to actually output the records and then "force" bulk upload them using Salesforce's own Dataloader desktop client which was completely successful.


Any idea if this was BULK API related or a bug in my workflow?

Alteryx Certified Partner

aMac, have you added fields to the SFDC object recently or are you inserting based on a key value? Are all the key values present in their source? 


This was an attempted 'Update' Operation, so the only key value I needed to supply was the Salesforce Record Id which I did. All the other values were non-indexed read/write values


I have the same issue.

My workflow updates Salesforce Account object - only one custom field Date_of_last_invoice__c.

I am SFDC admin and have no restriction to update the data (did before with Jitterbit Data Loader).


In my workflow I provide just two values:

- Account Id (to match with SFDC Id)

- Date


It did work for 19k records, but failed for another 11k.


The error message was:

00:51:0.945 - ToolId 104: Number of records read: 19189

00:52:33.096 - Error - Alteryx: Tool #105: Record-level error from Salesforce API: "FIELD_FILTER_VALIDATION_EXCEPTION:You must select an Account of Type Buying Group.:Buying_Group__c --"

00:52:33.098 - Alteryx: Tool #105: 19189 records processed and 1 failed across 2 batches


I don't have any such validation rule on accounts, neither I was updating Buying_Group__c custom field.

I use Alteryx


Any ideas?

This post is already 4 months old.



Hi Tomasz,


Is there some lookup defined on the object you are trying to update.

Please check difference between the records which got updated and which failed to get updated for the field error message is showing.

Might be some validation rule (lookup filter) is getting fired even if you touch/update that record without necessarily performing update on the lookup column.



Rohit Bajaj


I am still encountering the "field headers do not match row"  issue, most frequently for an alteryx flow that writes tabularized records from a web scraper tool into a custom SFDC object.


I tried modifying the URI in the Salesforce Output tool to bump the API version from v20.0 to v31.0 but the same error was returned.


Is anyone aware of a custom Salesforce connector available from the public gallery that does not use the Bulk API but uses the "normal" REST API instead?