community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
SOLVED

SQL Server - "unable to translate alias" when I save my workflow to the gallery

Asteroid

I could not find an answer to my specific question in the existing posts... can someone tell me how to resolve this?

 

This is in Alteryx 11.0.

 

I have a workflow that uses a SQL Server data source, defined with alias name "Emcompass DW"

AliasSetup.JPG

 

And in the Gallery I have created a data connection with the same name:

 

GalleryDataConn.JPG

 

And I shared it to myself.

 

But when I try to upload my workflow to the gallery, I get the "unable to translate alias" error:

 

GallerySave.JPG

 

 

Alteryx Certified Partner
Alteryx Certified Partner
Remember when working with Alteryx server, applications and workflows are not ran with your credentials but instead the Alteryx server run as user, so it’s this account that needs to have visibility to the alias and connection.

Ben
Asteroid

Sorry, I don't fully understand your reply.

 

To add more context, the same workflow also uses an Oracle alias which had the same issue at first when I saved it to the gallery.

 

I checked the existing data connections and found one in the list that matched the server\database my locally created alias was using, so I changed my workflow to use that already existing data connection. This resolved the "unable to translate alias" issue for the Oracle alias.

 

Even though my SQL Server data connection has been shared with my user id, I think your reply is saying that I need to share it with the Alteryx user account ("...but instead the Alteryx server run as user") - is my understanding correct?

 

FYI, the Oracle alias that works in my workflow is only shared with one person: another user\employee.

 

Can you provide some additional clarification?

 

Thanks

Alteryx Certified Partner
Alteryx Certified Partner

Unfortunately I was just hoping to give you some direction, i'm definitely no expert with this subject though i'm slowly getting more exposure to it.

 

I'll point you at a few posts that may clear things up for you:

 

https://community.alteryx.com/t5/Alteryx-Connect-Gallery/Unable-to-Translate-Alias-when-Publishing-A...

 

https://community.alteryx.com/t5/Alteryx-Knowledge-Base/Database-Connections-Creating-an-alias-and-t...

 

If you don't get more traction with your community post i'd suggest pushing it to Alteryx's more formal support channel: support@alteryx.com

 

Ben

Asteroid

Will do. Thanks!

Alteryx
Alteryx

Hi @JDelgado,

 

The 2 Alias' that you are talking about are different. This is a slight bit of confusion as we added in extra functionality to allow connections to be managed from the Gallery. I'll try to separate the 2 different methods to explain (Sorry about the length if you just want the answer):

  1. The first is the method that has always been in the software (at least for several years) and is documented in the above linked post on Creating an Alias. This involves creating an Alias on your machine and then also creating one through 'Options > Advanced Options > Manage Data Connections' (be careful to make sure that it's a system connection on the server or that it's set as the user that the Server runs as). The way this will work is say if you have an Alias called Teradata, on your machine it may point to a development instance of your Teradata server, but on the Server, it may point to the Production instance of Teradata. But all the workflow stores is 'aka:Teradata'.
  2. The 2nd method is setting up Data Connections in Gallery. this was introduced about 1-2 years ago and allows you to set a data connection in the Gallery, and then that is exposed to end users via the 'Input Tool > Saved Data Connections > {Gallery Name} > {Connection Name}' as in the image below. This is extra functionality (not a replacement of functionality) that was added to allow admins to manage connections for many users from the gallery.

 Gallery Data Connections.png

 

These 2 methods are not interchangeable for one main reason. As you can see in my screenshot there, I have 2 Galleries that I connect to, I just cleaned it up from 6. So, If I had an Alias called 'Teradata' in 2 of those galleries (remember they don't know about each other) then Alteryx wouldn't know which one to use. Hence, in the underlying workflow, that connection is stored as 'aka:593f76fe596b370bb0aabea8' using a  unique Id for each alias rather than the short viewable name.

 

Extra info: So if you are trying to promote workflows from a Dev Server to Prod Server using Alias', then you need to use Option 1.

 

So, with your issue here, you can either:

  1. Set up the workflow to use a Saved Data Connection through the input tool and link the Gallery Connection, or
  2. Set up a Data Connection through Manage Data Connections on the Server that is the same name as the one in your workflow.

Please let me know if this is still confusing.

 

Kane

Asteroid

Great Info, thanks!

 

It explains my resolution, I think:  I ended up deleting the existing data input tool which had created with a local data connection alias, and creating a new data input tool that used the Gallery Data connection after I created it (the data connection on the Gallery).

Meteoroid

Hi @KaneG,

 

1)

I'm still confused. I do not have admin rights on the server, so I'm going with the first route. When I add a connection to the serve, via Saved Data Connections > My Company's Gallery > ManageI add a connection but it doesn't appear in the available connections on the server. Rather, it is stored under My Computer. See screenshot below.

alteryx server.jpgAfter I've created the data connection here, when I go back, its not under the gallery.

 

I'm a little frustrated, as I think this should be an easy process, but our IT department doesn't know how to support this and I've tried just about everything with no success. Is there a step-by-step guide, with screenshots, available that walks through this process in detail? Every post I've seen on this assumes a lot about the user and level of support.

 

2)

When I (unsuccessfully) add to the Gallery, the resolution and proportions of the App change. See the Results window in the screenshot above. Is this a known bug?

 

Thanks

Don't we have any answers for this post from rerwin21. I am also facing the same difficulty and am at same point. Any expert please reply to the post 

Highlighted
Alteryx
Alteryx

Sorry, I hadn't seen these replies. When adding Data Connections via Manage in that screenshot, the connections will always be added as "User". This just takes you to the Data Connection Manager, not a specific one for the Gallery.

 

In order to add them as Gallery Connections, they would need to be added under the "Data Connections" section in the Gallery Admin and then shared with users. There is no way to add connections to the settings of the gallery from the designer, that would be extremely hard to get good governance on.

 

As for the resolution change, I'm not sure, but guessing it may have been fixed in an update. 

Labels