community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
SOLVED

SMTP issue

Asteroid

Hello Alteryx community, and happy Friday!!

 

I have a very simple workflow, whose last step is to email after run without errors a small data set.  The problem I am having is that when I run the workflow, I get "Error: Designer x64: The Designer x64 reported: SMTP path must be specified"

 

We use Gmail where I work, so I have tried smtp.gmail.com, smtp.gmail.com with the port number added.  I am not sure what else to try??

 

 

Alteryx Certified Partner

I don't think you'll be able to use the Email tool with a gmail account right out of the box since it doesn't provide a way to authenticate your sender account credentials. It may be possible if you configure the IP-based authentication outlined on this Google support page:

 

https://support.google.com/a/answer/2956491?hl=en

 

As for alternative options, I found this online that outlines how to use PowerShell to send emails from gmail. I'm sure with a little work, you could use the Run Command tool in a solution to send email, from a Gmail client, that is kicked off from an Alteryx module.

 

https://www.howtogeek.com/120011/stupid-geek-tricks-how-to-send-email-from-the-command-line-in-windo...

 

Hopefully others can chime in with more/better options.

Highlighted
Asteroid

CharlieS, thank you for the quick response.  I will study what you have written.  it is my understanding that before the latest version of Alteryx this process was much simpler to implement, with the auto-detection of SMTP.  I wonder why Alteryx would change their software so that a workflow requires more steps now to email.....

Alteryx Certified Partner

Happy to help!

 

Yes, the latest version of the tool does not auto-detect the SMTP path (for security reasons), but it doesn't change the (in)ability of the Email tool to send the sender account credentials for the server to authenticate. That authentication is controlled by the STMP server settings. 

 

For example, with my company's current SMTP settings, I can only use the Alteryx Email tool to send emails from certain global noreply accounts since that only validates by domain/IP. I am unable to sent emails from my individual company email from the Alteryx tool since it has no way of saving/sending my credentials to the SMTP server.

Asteroid

I think this could potentially be a solution.  Still investigating :)

 

https://inviso.dk/blog/post/inviso-macro-pack-gmail-integration-

Asteroid

I could not figure out how to make the Inviso macro work, so for now there is no "easy" solution as far as I can tell.  

Alteryx
Alteryx

Hey everyone,

 

For those of you following this thread, as of the 2019.3 version of Alteryx Designer we have authentication functionality within the Email Tool. Users can now enter their credentials (username & password), select an encryption method, and connect to the appropriate port number.

 

If you are interested in connecting to a Gmail or other email service that was not previously supported by Alteryx Designer, please refer to the following knowledge base article to learn more on how to do so.

https://community.alteryx.com/t5/Alteryx-Designer-Knowledge-Base/How-To-Send-Emails-Through-Gmail-Us...

Labels