community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
SOLVED

Run Command failing on scheduler

Asteroid

Hi,

 

I've built a really simple ETL, it has 1 command, RUN a bat file with a python script inside. If I run the file on the command it runs fine, if I run on Alteryx it runs fine, in Scheduler it fails with:

 

Start: Designer x64: Started running at 2017-02-07 15:24:21
Error: Tool #14: The external program "C:\Users\xxxx\Desktop\ETL-Alteryx\bigquery\donor_last_touch\donor_last_touch.bat" returned an error code: 1
End: Designer x64: Finished running in 3.9 seconds

 

Any ideas?

 

Thanks

Joao

Alteryx
Alteryx

Hi @joao,

 

This is most likely related to the user that is running the script. The scheduler uses a windows user, not your user account and so may not have access to the details inside the batch file. You can set up the 'Run As' user in System Settings on the machine with the scheduler.

 

Your other option is to add ' > C:\outputlog.log' to the end of the batch command to write the output of the cmd window to a log file and see what the failure is.

 

Kane

Asteroid

I right click on the .bat file and can't find the Run As option.  I tried the log it is empty. The ETL runs fine if I run it by hand. What should I do?

 

Thanks

Joao

Asteroid

Ok solution 3: Run the scheduling service as the same user. End of problems! :)

 

Thanks

Joao Correia

Meteor

@joao Could you tell me how your configured the scheduler to run as same user? I am running into same issue in scheduling a workflow that has a batch file. 

 

Thanks

Alteryx
Alteryx

@ztamjeed

 

This can be done from your Alteryx System Settings application. From Alteryx Designer, Options -> Advanced -> System Settings.

 

You'll find the Run As settings under the worker section of the configuration.

 

https://help.alteryx.com/server/11.0/admin/index.htm#Configuration/SystemSettings/Worker.htm?Highlig...

 

-Mike

Mike Spoula
Solutions Architect - Services
Alteryx
Atom

Hi,

 

I'm running my scheduler as my windows account but i'm still getting an error when trying to run the batch file in scheduler? if i run it manually it works fine.

 

on scheduler it throws the same error as you reported

 

 

Meteoroid

Hello guys,

 

We were facing the same issue as you mentioned. We were not able to refresh the excel file through scheduled workflow using VBScript.

 

I Googled it a lot and finally came across one post which helped us resolve the issue. Hope it helps you guys too

 

"********  Link

Faye: 

I had the same issue and fought with it for a few months. Finally resorted to calling Microsoft for some assistance. The fix isn’t something I would have ever found, so hopefully this helps others too. The script would run fine when I launched it in Powershell (and command line) but when it launched as a scheduled task it would run but not with expected results. Microsoft informs me that my issue is with running Excel in “non-interactive mode”, you require two directories to be created.

You have to create a folder (or two on a 64bit-windows):
(32Bit, always) C:\Windows\System32\config\systemprofile\Desktop

(64Bit) C:\Windows\SysWOW64\config\systemprofile\Desktop

The MS Excel when you are trying to run in non-interactive mode will look for this, if it is not present it will not open in the non-interactive mode.

once these were created the scheduled task runs flawlessly.*******"

 

Alteryx Partner

Hi Dev,

 

I am also facing the same issue.

I have to run a VBS file through wscriot. When we run it manually, it does not throw an error but when we run through scheduler it is showing timeout error.

Could help us on this.

 

We have tried making a folder:C:\Windows\SysWOW64\config\systemprofile\Desktop but then also same error occur.

We have 64 bit windows , so what do you mean by two folders.

 

Thanks

Regards

Nipun

Highlighted
Alteryx
Alteryx

@Nipun 

 

With 64 bit Windows, it requires the second folder in addition to the first. So you will always need C:\Windows\System32\config\systemprofile\Desktop, and if you are using 64 Bit, you will need C:\Windows\SysWOW64\config\systemprofile\Desktop in addition.

Regards,
Stephen Ruhl
Customer Support Engineer

Labels