community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

Run Command batch file creating file instead of file folder when I use mkdir?

Asteroid

Hi, I'm trying to run a workflow that creates a folder when I run it. I'm using the Run Command and batch files to make it.

 

My command is "mkdir %Engine.WorkflowDirectory%" + [FolderName] and the Data Preview shows everything working out. But when I run the workflow instead of creating a folder it creates a file called [Folder Name].

 

I think it's a problem in Alteryx because when I run the batch file on its own the folder is created fine.\

 

 

Alteryx
Alteryx

@helenjin1 

 

I'm not sure whether the example you attached is the one you tested and failed to do what you needed it to. The Formula tool requires an Input so I've added a DateTimeNow Tool, de-selected the new field created and ran the workflow. The folder got created as expected

 

run-command.png

 

folder.pngThe folder that got created

 

 

 

 

Asteroid

Huh that's odd, I do have an input but I didn't want to upload it with my example. I thought there was something wrong with my run command settings but I think I'll restart the application and try it again.

 

Thanks for the reply!

Labels