community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
Upgrade Alteryx Designer in 10 Steps

Debating whether or not to upgrade to the latest version of Alteryx Designer?

LEARN MORE
Alteryx Gallery is experiencing a problem in which system emails are not being sent out. As a result, if you are attempting to sign up for a new account, you may be unable to verify your email address. We are working to solve this as soon as possible and will remove this notice once resolved.

Rendering to a temp Excel file... how to format number fields with no comma separators?

Quasar

After rendering to a Temporary Excel 2007, my number fields default to include comma separators. How to I set this up in the table or render tools so that the numbers appear with no comma separators?

 

In other words, in the final render I need to see 12345, not 12,345.

 

I can change to a vstring but then Excel red flags every cell as "number stored as text". 

Pulsar
Pulsar

Hello @ddiesel. Try adding a Select tool and changing your field to a string first. Then in Excel, you can convert it back to a number.

Quasar

Thank you @BarnesK

 

This is built into an app that emails out the processed file to end users. Is there any other way?

 

I don't want to have the end users change the number format in excel. The numbers refer to client numbers that are between 3 and 9 digits. They don't look right with the comma separators. As a string, excel red flags the fields.

Atom

I have run into the same issue, 20 or so out of 1800 records have commas within a number field of data in the output of the render, but prior to the table tool if I include an output to xlsx there are no commas.

 

It's odd that is only happening to around 20 and I can't figure out any fixes for this.

Quasar

I'm still looking for a solution to this.

 

@atb4y8 - Strange that in your case it's only happening to some of the records. Does it have to do with the number of digits?

Atom

It doesn't have to do with the number of digits. I tried to converting to string prior to the table tool and then using a column rule to remove any ',' and convert back to number, but got the same results. Four other sheets in the output are using the same data and don't have the same issues. I have remove formatting from this particular sheet and now it works fine. It's not ideal, but it works for now.

Quasar

@atb4y8 so we are in the boat then... formatting removed and is not ideal. I'll keep you posted if I find any other solution. 

Labels