community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
Upgrade Alteryx Designer in 10 Steps

Debating whether or not to upgrade to the latest version of Alteryx Designer?

LEARN MORE
Alteryx Gallery is experiencing a problem in which system emails are not being sent out. As a result, if you are attempting to sign up for a new account, you may be unable to verify your email address. We are working to solve this as soon as possible and will remove this notice once resolved.

Refreshing problem with select and transpose tool in analytic app

Atom

Hi,

I'm building analytic app now. Bascially, I need to download the input file every time and use the transpose tool and select tool. The problem is that those tools won't refresh. For example, I may have 2016,2017,2018 as my field name after using the transpose tool. But every time I change the input file, those data don't refresh.

Capture.PNG

I have tried to use chain app(input the data first and do the manipulation) to do that but it seems it doesn't work. Could anyone help me?

Thank you very much!

Alteryx Certified Partner

Hey @Altasxx

 

Yes, these don't refresh if there are certain tools between the datasource and the interface tool.

 

Can you plug your input direct into the listbox?

 

What is your transpose tool doing?

 

 

Atom

Hi,

Thanks for the reply. But I think it doesn't work. I need to do the pivot stuffs. It won't work if I just connect the listbox to the data source.

Atom

Hi,

I have tried to link the select tool directly to the input. However it still doesn't work. Could you please tell me how can I let the input data refresh when I use the analytic app? I think maybe this is enough for me to continue on my own workflow.

Thank you.

Pulsar

Can you post some dummy data, or a screen shot of before and after your Transpose?  What kind of "pivot stuffs" are you doing?  The Transpose tool only creates two additional columns, Name and Value.  So if you need the years as options in the List Box, do you already have 2016, 2017, 2018 as fields in your data before you Transpose?

Labels